All Activity

This stream auto-updates     

  1. Yesterday
  2. Three finger Swipe on Client

    Moved to Feature Ideas to better reflect the nature of this post. It's my understanding that gesture support is coming in Synergy 3, which should be fully available in 2022 and as an alpha later this year or early next year.
  3. Hey, for this type of case, it's recommended that you go ahead and start a support ticket here: so that a support technician can help you one-on-one.
  4. Not able to get synergy 2 to work.

    Yup. As far as I'm aware, Synergy relies on broadcasts for service discovery instead of unicasts and since routers don't forward broadcasts, you usually can't go across subnet boundaries with Synergy.
  5. Not able to get synergy 2 to work.

    Have you tried Synergy 1 to see if this works? You should be able to have Synergy 1 if you have Synergy 2 and you can download it from the same account panel. If not, please establish a support ticket with Symless and they'll get your account sorted out.
  6. Hey there, forum users! I hope everyone's been able to use Synergy without much ire and that people who have experienced issues was able to get the help they needed through one of our various support channels (official ticketing system, Synergy forums, or Synergy Slack). For users who want to get help through the Symless forums, we want to make sure that not only can they find posts about people who have similar issues to them so that they can contribute their opinions and experiences to it so that Symless staff are aware if it's a bug that urgently needs to be fixed, but so they can also sift through the replies. Necroposting, defined as when a user (usually on a message board of some sort) posts on a post that is considered "stale" or "dead" as to make it prevalent on the main screen of the discussion category, makes it so newcomers to a post can't as easily find what they need to because often, these dead posts have a large number of replies. As such, if you see a post that is several years old with no recent activity, please help us keep our forums organized for newcomers by leaving the post be and starting a new topic unless you were the one that started it and a situation has arisen where the same scenario is still an issue for you and no one has successfully helped you yet. If it's a similar issue but your case is different than theirs, please go ahead and start a different thread. It helps us keep the forums organized and well-kept for people looking for community resources on an issue and we'd greatly appreciate if you help us with this! As always, please do not hesitate to message an active moderator with any questions. Thank you! Kelvin Tran
  7. Last week
  8. Three finger Swipe on Client

    Just figured I'd add another voice to the chorus of "please make the full range of trackpad gestures work on Mac". Or, at least make it clearer that they DO NOT work. It's really quite awkward to have to adjust to certain things feeling missing/broken on all macs but the server. In my case, my "client" machines are not infrequently used or of lesser priority—both machines are fairly fundamental to my workflow, and it would be great if we could use the gestures on both. Thanks for your consideration. (This is one of those situations where source code access would be great, too, as I could explore fixing it myself)
  9. Not able to get synergy 2 to work.

    I just had this problem and it was because one computer was on a different network than the other. Once they were both on the same network, it connected immediately.
  10. Some observations about the screen/mouse freezing problem.

    Hi guys I have an update for this issue (courtesy from the GitHub community). An update to the libx11 package may be the trigger for this issue, downgrading the package libx11-6 to version 2:1.6.4-3ubuntu0.1 solves the issue on my machine Use the command (Also remember you may be running the "hack" version of synergy. you may want to test with the release version 1.10.2 instead) sudo apt install libx11-6=2:1.6.4-3ubuntu0.1 #Reboot may be required this will downgrade the package but the package will still try to update, it's not recommended but if you wish you can hold the package to prevent it from updating with the following command sudo apt-mark hold libx11-6 Could people please report back on any success or failures of this fix with any details that may be important like OS version and the version of synergy your running.
  11. Changing the Function of Scroll LOck

    I too have this same setup, specifically with the "Cool Master- CMStorm" keyboard and mouse combo. The keyboard lights up only when the scroll lock button is activated. Its a software/firmware thing I'm guessing, since you can toggle the scroll lock from another keyboard attached to the same machine or even the virtual on screen keyboard and it turns the backlight on and off. Is there perhaps a editable registry key or some other hidden configuration file within AppData perhaps, that will allow the screen lock toggle to be mapped to perhaps the pause button on the keyboard (the key to the right of the scroll lock on a US Standard keyboard QWERTY layout) in Synergy2? Aside from that, I've been using Synergy for years, bought Pro license as soon as it came out, and am so thankful for the magic y'all do. Much love.
  12. Hey folks, I am running into this problem, previously reported: My Synergy server is a Windows 10 fully updated; the client is Fedora 30. If there is a full-screen window open on the Windows server, scrolling on the client also scrolls the window on the server. I'm running the latest version on Windows, and this on Linux: [[email protected] ~]$ synergyc --version warning: synergyc is deprecated. instead, use: synergy-core --client synergyc 2.0.0, protocol version 1.6 I know I'm not the only one with this problem: anyone run into this and found a fix? I've tried various option switches on the server side that I don't understand, but nothing works. I'd appreciate any pointers! (P.S. I know there is a version mismatch, but I really doubt this is the problem. I could be wrong.) EDIT: I'm using Synergy 1 basic (although I paid for a lifetime subscription, not sure why it's basic...) Merc
  13. macOS Mojave releases a week

    Thanks Valor. I had the same problem symptoms as everyone else, using Synergy 1.10.2. I didn't do any deinstall or reinstall. I first unchecked Synergy in System Preferences, then I clicked the minus to remove it from the list. Then I closed System Preferences. Then I opened Synergy again and I was able to enable it in the System Prefences, and it worked. @Joel Gray, this works for me with my Mojave Mac either as the server or as the client. In this case my other machine is a Windows 10 machine, which is happy either as server or client.
  14. Official Roadmap and Feature Vote

    Understand that your votes for Synergy 2 features are important and the Synergy Team has taken them into consideration when building out the application into a more mature release! Synergy 3 alpha, though it has been delayed, is undoubtedly on its way with the features you guys asked for most! Get excited, because it's coming!
  15. iPadOS Support

    This is similar to the issue with adding ChromeOS support, but emphasized by magnitudes because of how enormous of an undertaking this might be. Apple does not like you tampering with their accessibility stuff, and it makes sense. Accessibility features on both iOS (by extension: iPadOS) and macOS can cause security risks if put in the hands of a untrustworthy app. But with macOS, it's not justifiable to prevent users (particularly power users) to go in and modify accessibility settings to play to their advantage, so they allow for that with a discouraging message stating that it might compromise security. That's why Synergy works on the Mac. But that same reason is why Apple isn't going to post them onto the App Store - the entire premise of their app is playing with Apple's accessibility features, and very few apps that do that make it to the store (with notable exceptions, such as Magnet). With iPadOS though, you don't have that same degree of flexibility with regard to security measures. Far from it. So, Synergy would have to either get posted to the App Store (possible but unlikely and if they did, with large amounts of changes that would go against the purpose of the product) or do what GBA4iOS did a few years back and exploit tricks in the iOS app installation security hoping not to get detected and shut down by Apple (which also ended up happening). Additionally, couple this with the fact that even with the new SDK that allows for conversion of applications from macOS to iOS and vice versa, it's still really hard to convert the app to being compatible with iOS because of how deeply it plays into the macOS environment, and it's just not worth the extra risk, effort, and more for a feature that, relatively speaking, probably won't be widely used. Sorry, but it's likely not going to happen.
  16. Can you send a screenshot of the Synergy 1 interface on all machine(s) involved in the setup? I'd ask for logs, but I really doubt they'd help with your particular scenario. If I may ask though, why are you using a static config for your server? Does autoconfiguration not work in your environment for some reason? I do know that that's the recommended use for Synergy if you can because it'll use Bonjour to auto-discover the server service on the network. But I know there are cases where Bonjour packets are blocked by certain intranet firewalls within corporate organizations, as an example, so I'd just like to confirm why your network won't support autoconfig.
  17. Due to issues after an upgrade to Windows 10 1903 I went back to Synergy 1. But it doesn't remember the hostname/server IP on my Macbook when I reboot after the installation, instead of shutting down and starting up. I did a fresh install with the instructions multiple times. The only time I got it to work was when I switched to server-config and then back to client, for some reason it remembered the client settings afterwards. But oddly then it keeps asking for the server config file after every boot, even if it's set back to client mode. So now every time I reboot the Macbook, I get a prompt from Synergy, telling me that I have to fill in the host name. I uninstalled, rebooted and reinstalled multiple times with the instructions linked above, also - FWIW - with the version of those instructions for Synergy 2. Other steps I tried: • Toggle the setting in system preferences / Security • Toggle the autostart setting in system preferences. • Tried using the host machine name instead of the host IP, but it then tried to use the IPv6 address and failed to connect. The only way to get rid of the problem was to shutdown completely and then start the MBP normally.
  18. Erroneous Character Insertion

    I've split this off into a separate topic. I would recommend sending in a support thread through the Symless website.
  19. ChromeOS

    I'll lock the topic now. Final verdict: until announced later on down the line, Android/ChromeOS will not be officially supported releases. If you need ChromeOS, you can try Linux emulation. Be warned, however, that will take work.
  20. 32bit linux

    Try this link instead.
  21. [LOCKED] Synergy loses ability to click in client

    I am locking this thread. 103 replies makes the usefulness of this post for any newcomers quite questionable at best, or at the very least, a pain in the butt to dig through. Please start a new thread on the forums if you wish to have community support or follow the suggestions of our two fantastic support engineers, @Alexey Pilyaev @Daniel Alarcon and submit a ticket in the support system. Thank you, all, for understanding.
  22. Problem with Hyper-V Virtual Network Interface

    Hi there! I'm sorry you're still having this issue and that no one responded to your post dated 2017. I haven't been on the Synergy project for a good while, so I implore you to please excuse my rustiness on the Synergy material. In Synergy 1, there should be a way that you can select network adapter affinity for the application. Better yet, you can set a static IP for the server on your clients. As far as I'm aware, on Synergy 1, it's a client-to-server connection topology. So, theoretically, if you manually force all client(s) to connect to the server IP (which, presumably, would be on the 192 subnet), it should be forced to use your external network adapter since a route wouldn't exist for the other subnet on your default switch. Try it and let me know how it works out for you. Again, I apologize for the lack of activity on this post.
  23. 32bit linux

    The Ubuntu 32-bit link doesn't work, I get sent to this page: . Instead of starting a download, all I see is some XML indicating an "AccessDenied" error code.
  24. Bad Customer Service

    @topherlee Hi there, thanks for reaching out to us, and thanks for the feedback. It appears that you're unhappy with our response time. I'll do my best to get this corrected for you. It looks like Daniel responded on Jul 05 asking if you'd like to do a remote screen sharing session, but he didn't get a reply back from you. Perhaps the email went to your spam folder? If it's ok with you, we'll reach out to you directly so that we can move forward on this.
  25. Bad Customer Service

    Hi @topherlee There seems to be a bit of misunderstanding there, The support hours are 9AM GMT time till 5PM PST (edit: corrected times) Thanks Jamie
  26. This can be closed, I got a new server computer and it works without me having to mess with it.
  27. Earlier
  28. Bad Customer Service

    Are you Fricking kidding me 9am to 12am UK time is 2am to 5am salt lake city, Utah US time!!!!! do you really think that time works for every one???????? and that link you sent me is the same link I used the first two time!!!!! I tried to get help! is there "ANYONE" in the US on US normal time that can help me? Hell I would even be willing to drop what I'm doing go home to my computers so I could get help!!!
  1. Load more activity