Jump to content
Get Synergy | Open a support ticket
Symless Forums

Leaderboard

  1. eddier

    eddier

    Synergy User


    • Points

      2

    • Content Count

      4


  2. adfaklsdjf

    adfaklsdjf

    Synergy User


    • Points

      1

    • Content Count

      1


  3. Dominique

    Dominique

    Synergy User


    • Points

      1

    • Content Count

      2


  4. Knehp

    Knehp

    Synergy User


    • Points

      1

    • Content Count

      1



Popular Content

Showing content with the highest reputation since 06/08/20 in all areas

  1. 1 point
    Going in to server settings (Configure Server), then Advanced Server Settings, and disabling Synchronize screen savers, then applying that, will allow clients to follow their own sleep schedule. Strangely, the server on Windows will not apply a display lock, but, the client will if that setting is enabled. Disabling that causes synergy to release it's lock and the screen/s on windows clients will follow the configured screen power off timer on them.
  2. 1 point
    I initiated a Support ticket and they replied that they are aware and working on a solution. Until then I set my Windows monitor to one I can easily access the power button, the others are more difficult to access in my setup so they are on the Mac so that the screens will turn off properly. Hopefully they get this resolved so we can properly use our systems.
  3. 1 point
    So, the Secure Input is definitely the problem and a fair # of apps can hold onto it, causing problems with Symless as well as other apps like ShareMouse. I found a solution of how to find and kill the process causing problems by searching/browsing a bunch of forums (sorry forget where exactly I think a reddit post). In anycase, for those on the Mac who are ok with Terminal commands here's what you can do when you are using your Mac as the server (master) and suddenly your keyboard stops working on your clients (slaves) i.e. it's stuck on your Mac. Warning: if you're not comfortable typing in the Terminal various shell commands, better not go this way. Manual instructions: 1. Start Terminal. When this happens, open up Terminal app on your Mac 2. Find the Process ID holding onto SecureInput mode. Type in this command and Enter: ioreg -l -w 0 |grep SecureInput If it returns nothing, then you actually shouldn't be stuck or SecureInput is not the problem. But if it is, you'll see something like: | "IOConsoleUsers" = ({"kCGSSessionOnConsoleKey"=Yes,"kSCSecuritySessionID"=100006,"kCGSSessionSecureInputPID"=1433,"kCGSSessionGroupIDKey"=20,"kCGSSessionIDKey"=257,"kCGSessionLoginDoneKey"=Yes,"kCGSSessionSystemSafeBoot"=No,"kCGSSessionUserNameKey"="joeblogs","kCGSessionLongUserNameKey"="Joe Blogs","kCGSSessionAuditIDKey"=100006,"kCGSSessionLoginwindowSafeLogin"=No,"kCGSSessionUserIDKey"=501}) The kCGSSessionSecureInputPID is the process ID of the offending process...in this case 1433 above. 3. Kill It a) You can then look in Activity Monitor for this PID (sort by the PID column), select that row, and kill it (Quit it or Force Quit it) b) Or if you want in Terminal, find the process name with: ps ax |grep <PID> where <PID> is the actual numeric value e.g. ps ax | grep 1433 This shows you the process that's causing the problem. Next kill it with: sudo kill -9 <PID> and you'll need to type an admin password just in case you don't own that process NOTES: Sometimes it's something like 1Password and you're good to go, just restart the app if you need it. Other times, it's been the MacOS Login Console or something like that, and when I kill it, I'm immediately logged out and when logging back in, all my windows have been restarted (almost like a reboot) -- possibly b/c all my apps were started by the Login Console process. Regardless, this is just a warning that this may happen. For me, it's still better than a full reboot, and I now have a way to at least move beyond this problem.
  4. 1 point
    @eddier - I just had the same problem with 1Password on my iMac, which is my Synergy server. When I had the app open, I could not type on my MacBook Pro, which is my Synergy client. This would have driven me crazy if I had not found your last post. Thanks!
  5. 1 point
    This kind of seems like a bug that is still happening. I've had it happen lots of times before and I believe clicking the "Configure server" button and then "OK" would fix it. I just had it happen now, Googled, found this thread, and did the uncheck/recheck server fix and it worked, and I'm noticing this: After unchecking and re-checking the server checkbox, the config file it finds is in a temp directory. Is it possible that windows is cleaning up this file, and the uncheck/re-check re-creates it? The server is Windows 10. The client is a Macbook
  6. 1 point
    Dominique, great insight. I think you're correct. I am able to reproduce at least one case with 1Password (password manager) on the Mac (used as my master). When I bring up 1Password (where it goes into Secure Input mode with its own password), don't log in, but their dialog is still up, cursor is in that dialog, then switch over to my WIndows machine (slave) using Symless, I get into the state of: mouse worked, keyboard input still on the Mac. If I then go back to my Mac and kill 1Password (actually just dismiss the dialog), then everything is ok. I'm not convinced that this covers all the times I have problems, but I'll see if it reoccurs, and at that point try to see if there's a background window for 1Password or any other security-related app still running or sitting around. Thanks for the pointer to ShareMouse--it has really good features.
  7. 1 point
    More info... When I use ShareMouse (a competitor app I'm reviewing) on these machines while in this state the server instance has a menu option "Keyboard not working?" and this leads to "ShareMouse is disabled because an unknown App left "Secure Input" activated. Do you want to learn more?". After digging around this leads to the following support description: Mac only: If keyboard input is not transmitted/processed on a Mac, click the ShareMouse menu bar icon and check if ShareMouse reports a "Secured Input" error. The macOS system function "Secure input" protects sensitive text input (such as password input) from being tracked by other programs, which generally is a good thing. Unfortunately, some applications may not release this feature after use and any input stays invisible for 3rd party apps, such as ShareMouse. Work around: Disable "auto-submit" feature of any auto-login feature and/or close and restart the application, that caused the interference. Example: Safari may leave Secure Input enabled on secure web pages when option "User names and passwords” is enabled in Safari Preferences » Autofill tab. Solution: Disable the option to avoid the Secure Input lock-up or alternatively close the Safari window you have open or restart Safari. So it would seem that the ShareMouse folk are aware of this problem and are able to identify when it may be occurring and provide information to the end user about it. Nice.
  8. 1 point
    I see @Dev. Please try setting the elevation level of Synergy on your Windows machine to "Always." Click Edit Click Settings Set Elevate to Always Click OK Click Apply or Start
×
×
  • Create New...