Jump to content
Get Synergy | Open a support ticket
Symless Forums

Leaderboard

  1. Daniel Alarcon

    Daniel Alarcon

    Synergy User


    • Points

      14

    • Content Count

      118


  2. Nick Bolton

    Nick Bolton

    Synergy Team


    • Points

      8

    • Content Count

      2445


  3. Jamie Newbon

    Jamie Newbon

    Synergy User


    • Points

      7

    • Content Count

      50


  4. Alexey Pilyaev

    Alexey Pilyaev

    Synergy Team


    • Points

      5

    • Content Count

      273


Popular Content

Showing content with the highest reputation since 01/18/20 in all areas

  1. Hi, There is a development build available that has a fix for this issue in it, could you please give it a go Synergy v1.11.1-snapshot Thanks Jamie
    5 points
  2. Hello everyone, I am Kyle Bloom and a new developer here at Symless. I will be working on the user interface of the next major version of Synergy. Kyle!
    3 points
  3. Mine was working fine then it stopped and I was not sure why, after reading these posts I looked at my mouse settings and remembered that I turned on smooth scrolling in Logitech Options, so on a whim I turned if off and it started working again. maybe this will help someone.
    3 points
  4. I love Synergy! Very big hugs! Please build a 64bit ARM package for RasPi :) XOXOXO
    2 points
  5. Hi all, We're in the process of hiring a Community Support Agent who will man the forums (as well as the Slack and Discord channels) to help out when people don't want to open a support ticket. If you want to apply for the role: Apply online for the Community Support Agent role Thanks, Nick
    2 points
  6. Dominique, great insight. I think you're correct. I am able to reproduce at least one case with 1Password (password manager) on the Mac (used as my master). When I bring up 1Password (where it goes into Secure Input mode with its own password), don't log in, but their dialog is still up, cursor is in that dialog, then switch over to my WIndows machine (slave) using Symless, I get into the state of: mouse worked, keyboard input still on the Mac. If I then go back to my Mac and kill 1Password (actually just dismiss the dialog), then everything is ok. I'm not convinced that this covers all t
    2 points
  7. More info... When I use ShareMouse (a competitor app I'm reviewing) on these machines while in this state the server instance has a menu option "Keyboard not working?" and this leads to "ShareMouse is disabled because an unknown App left "Secure Input" activated. Do you want to learn more?". After digging around this leads to the following support description: Mac only: If keyboard input is not transmitted/processed on a Mac, click the ShareMouse menu bar icon and check if ShareMouse reports a "Secured Input" error. The macOS system function "Secure input" protects sensitive tex
    2 points
  8. @cooch17 This is normal Synergy setup, you can get up to 4 Synergy processes: synergys.exe (background Synergy service, you can find this in Windows services under Synergy). synergyd.exe (it's triggered by the synergys.exe service, this will run the main Synergy libraries required by Synergy). synergy.exe (the UI Synergy app). synergyc.exe (Synergy opens this when running as a client). Let me now if this answers your question.
    2 points
  9. Here is the response I received from Parallels support, which solved the issue for me in Parallels 14 (I ran the commands while the VM was shut down, but I don't know whether it makes a difference): To resolve the issue please, open Terminal (Applications > Utilities > Terminal) and execute the following commands: defaults write 'com.parallels.Parallels Desktop' 'HID Host Hook.Allowed Sources' "synergy" defaults write 'com.parallels.Parallels Desktop' 'HID Host Hook.Allowed Sources' "synergyc"
    2 points
  10. Funny how this has had so many voices and it's only now (possibly) coming in two more years. Today was my first use of this product, and the three-finger gesture was the first issue I found. Purchase, install, connection were all relatively smooth, then I hit the black hole of three-finger gesture. You'd have a pretty great product if it just did this one last thing. Now you are left with a product that people will eventually leave for a silly reason like not taking a few weeks to fix a limitation. You are supposed to be fixing customer problems, this is clearly a customer problem. It doesn't
    2 points
  11. Have a look here: https://github.com/symless/synergy-core/issues/6608 --> https://github.com/symless/synergy-core/commit/1bc2cf57d90533bc3a4f4a029f4bab74caa12275 Workaround: move/copy openssl.exe and synergy.conf from the OpenSSL-subdir to the Synergy program folder.
    2 points
  12. I had to sort through old information to get method right and, as is usual in these cases, one small detail was holding me up. Here's what I did to get synergy 1.10 to start at boot on my Pi 3b+ running the latest Raspbian as of this date. Credit Nick Cullen for the script. 1) Make this script in /usr/bin and name it something descriptive like startsynergy. Or name it Bucephalus if you want. It worked for Alexander. It's usual to give scripts an extension like .sh, but not necessary. I didn't use an extension. Whatever you name it, use the full name in what follows. =================
    2 points
  13. Had the exact same issue. Sam54123 and Johnmc's suggestion worked. Here are a few images to walk you through that process should you encounter the same problem:
    2 points
  14. It takes a little work, but it is possible to use Synergy over VPN without split-tunneling. Here is what I did. 1) Register yourself a free (or paid if you don't want 30-day nags) dynamic DNS address (DDNS) from a place like dynDNS or no-ip 2) Register for the Pro version of Synergy to get that sweet, sweet SSL security. You're going to be opening some pin holes, so best to keep the connection secure while in transit 3) Select a non-default port for Synergy to use - again security precaution From you home network router: 4) Create a DHCP reservation or assign a static IP for your s
    2 points
  15. Hi all, Is there any Synergy (1) rpm available specifically for Fedora 31? The CentOS rpm on the download page fails dependency checks (needs libcrypto.so.10, libssl.so.10). Version 1.10 of Synergy is available via the standard yum repos for the distro but I'm keen to make sure I'm running the latest version! Alternatively, are there any workarounds to get the rpm installed with any necessary dependencies?
    1 point
  16. I have a Mac server with a Winders 10 Pro client, and every now and again I open some program on my Mac and then my mouse works through Synergy, but my keyboard is always local on my server. I can't figure out what program is causing this behavior. Could be Microsoft Remote Desktop, any one of a couple VPN programs I use (OpenVPN and Big-IP F5) ... a reboot of the Mac server fixes it. Do you have any advice? Using latest downloads as of today on both client and server. I saw a previous post about Webroot, but I don't use that. I haven't installed anything today that might have ca
    1 point
  17. I have a question (and apologies if it has been asked prior) I have a setup that looks like this: Two different machines on the same physical KVM Switch that I routinely go back and forth between - we will call these Machine A and Machine B A second machine with its own dedicated monitor / keyboard / mouse - we will call this Machine C I have Synergy running as a server on Machine A I have a Synergy running as a Client on Machine C that connects to Machine A Is there a way for me to be able to have Machine C [b][i]ALSO[/i][/b] be a client to Synergy Server running on Machine B? Basically
    1 point
  18. Hi. With the added Raspberry Pi support in 2.0.9, has anyone managed to set up a headless Synergy server in Raspbian? If so, how was that accomplished and if not, is there a way this can be done?
    1 point
  19. I don't know if this falls under the coming features ("Tinker-y" Settings panel) or (Making the window size and elements dynamically adjustable) but I'd really like to see better position control for multi-monitor setups. I have two adjacent monitors to my main screen, but my right one is in portrait mode. So it is taller than the other two. My second computer screen is above my 1st computer's primary display. But I can't drag my mouse directly to it. I have to go to the taller screen to the right since it has the highest point of my setup. However, I'm able to move my cursor down to my main
    1 point
  20. System Setup My Server is a 2017 iMac and the client is a late 2012 iMac (both running 10.12.5), I also have a headless PC (This therefore does not have Synergy installed - running Windows 10 Pro and I log into that from Microsoft Remote Desktop), the server and PC are wired connections, the client is wireless. I have tested this with both 1.8.8 and 1.9.0 RC3 and the bug appears in both of them. Bug & Reproduction If I connect to my PC using MRD on the server everything functions correctly. If I log in from the client Mac, whilst everything functions correctly o
    1 point
  21. I have been experiencing this forever between my Mac and Host Windows PC. It's definitely a bug, as when you restart the SERVER side (Windows) box's Synergy Service, it corrects itself and copies well again. Since It's been such a persistent bug not fixed over dozens and dozens of versions... I developed this fix to save myself time. Create a batch file that has this in it: @ECHO OFF cmd /c "net stop "Synergy" & sc start "Synergy"" Then create a desktop icon or link that exists on the task bar you can click. You'll lose synergy access to your seocndary host of just a f
    1 point
  22. Greetings everyone! I am Daun Chung, and I am one of the new developers in Synergy, Looking forward to developing the next major version of Synergy! Thanks, Daun
    1 point
  23. This is an issue I have been having for quite a while now (maybe forever) and, until now, been lazy to report. My setup contains 3 machines. The master is a Linux (Linux mint 19.x) and one client is Mac OS (Catalina, now) and one Windows (10 version I-don't-know-but-recent). I am a bit loose on versions, because I had older versions of these OSes before with the same problem. When I want to type a quote or a double quote on my any of my machines, I type the following sequence: ' or " followed by a space. On the master, it all goes well as I get ' (the quote, 0x27) and " (the double
    1 point
  24. Hi Jamie, I tried this exact approach with the latest version of Synergy on Mac OS Catalina, and I was met with unsuccessful results. The desktop client interface did not change at all and still would not allow me to enter an IP address.
    1 point
  25. We do indeed have ARM64 binaries available, they were built on a Ubuntu 18 OS and can be selected on the downloads page
    1 point
  26. Any chance of a Synergy build for ARM devices running Windows 10? I was toying with buying a Surface Pro X, but I do pretty much live off of having my thinkpad as my primary input device for everything at my desk. I know, I'm a little fringe, but aren't all Synergy users?
    1 point
  27. I'm having the same issue where the mouse goes to the client machines but the keyboard input stays on the server. In my case I have a Mac and a Windows as clients and another Mac as the server. I've tried restarting the software on all three machines with no change in behavior. I believe the mouse/keyboard difference rules out the network as an issue, and I believe restarting the software with no change rules out the state of the software as an issue, I would suggest the most likely culprit is that OSX is not providing the correct keyboard information to the software, preventing it from f
    1 point
  28. You're actually over thinking a little. All you need is one of the several packages, like iDisplay, that will let you use your Android device as a secondary display. Since they are "just" a second display, Windows native mouse/keyboard handling is all you need. There are a number of packages, all with slightly different ways of working and their own advantages/disadvantages. My preference has been one of the ones that uses a wired connection -- less lag, no wifi or bluetooth issues, and I can use the laptop as a charger for the tablet. While I've never tried to use it, there is an
    1 point
  29. i've recently 'upgraded' to the surface pro x and am not able to use Synergy from it. It does install, and I can authenticate, but I'm not able to move the mouse on the other screen and the cursor gets trapped and I have to quit and restart. The Pro X is fun, I travel around to clients a lot so the LTE is a big help for me. Obviously some limitations due to the ARM chip. Chrome runs terribly for instance but using Microsoft's Edge Chromium beta as a replacement is going well given you can use all your Chrome plugins. Life on the fringe =)
    1 point
  30. @Luis A This is currently not possible in Synergy, I will pass this information to the dev team to consider for future roadmap
    1 point
  31. @Derek yes, there is a bug on the TLS certificate. We actually have an interim build that has this fix, if you would like to install that, please open a ticket here: https://symless.com/help/contact we can send you the download link for that build.
    1 point
  32. @Derek The latest Synergy version (1.11) allows custom configuration files.
    1 point
  33. 1 point
  34. I don't have parallel but use MS Remote Desktop. Just tried the following and not change: defaults write com.microsoft.rdc.macos 'HID Host Hook.Allowed Sources' "synergy" defaults write com.microsoft.rdc.macos 'HID Host Hook.Allowed Sources' "synergyc"
    1 point
  35. For what it's worth, this is a confirmed bug due to a bad port that got overlooked: https://github.com/symless/synergy-core/issues/6608 Just copy openssl executable and the conf file one directory up and you'll be good until the next release when things are corrected presumably.
    1 point
  36. Good news: we have totally reversed our stance on this. The next major version will have a full offline mode (optional cloud features). We realized that adding cloud dependency in Synergy 2 was a huge mistake. We have a number of users we have that use Synergy in air-gapped environments such as security, military, etc. Internet connections also sometimes do go offline. Then there's the privacy issue; we feel that it's important that people have a say in where their data is stored.
    1 point
  37. Some minor corrections / recommended changes: dpkg-deb -R whateverVersionYouDownloaded.deb nameOfFolder cd nameOfFolder mv usr/lib/systemd/system/synergy.service usr/lib/systemd/system/synergy.service.dpkg-new cd .. && dpkg-deb -b nameOfFolder synergy2.deb
    1 point
  38. Dunno who the appropriate booze recipient might be, but moving this to Feature Requests...
    1 point
  39. What sorcery did you do to even get 2 finger scrolling.....? It's like, giving us a solution but not enabling the spacebar. Really, who needs a spacebar? =\
    1 point
  40. Read more: We Are Putting UX First (Symless Blog)
    1 point
  41. The inverse works fine. But when I switch back the keyboard keeps not transferring, even after rebooting both client and server. I haven't replied for so long as this keeps happening on and off, and I haven't been able to find out a pattern that would cause it. Just to be sure, I have just installed the latest version right now, nothing has changed.
    1 point
  42. At least with the iPadOS Beta you can use a bluetooth mouse to point and touch anything on the screen. I think this is one of the new Accessibility features that they added in iOS 13 (You can use any 'pointing' device in fact -with the exception of the magic mouse and magic trackpad-). Perhaps now Synergy could be used to connect as a bluetooth pointer to the iPad? I hope you take a look into this. Anyway, thanks for your great work.
    1 point
  43. This issue has been haunting me for months. But I just find the strange solution at https://superuser.com/a/1323302/170017 Basically you have to apply some changes to the mouse scrolling speed. Then the scroll wheel (slide if using magic mouse) will work on client machine. I am able to fix it with out rebooting, just make it slow, click [ok], it is already working, make it max again, continue to work.
    1 point
  44. This issue keeps happening for more than 1 year on and off on my mac(server)+win10(client) as well, same type of network connection (mac-wifi, win10-wired).
    1 point
  45. Hi @Alsatian I still think I got lucky, and I'm no expert, but I'll try to explain what I did better so that you might try if it works: In my Mac the address is 192.168.1.65, And in my PC I have 4 addresses, one is in bold, meaning is the one recommended that you use, but the 3rd number does not match the Mac Ip Address. My Mac has a XXX.XXX.1.65, and my PC IP address thats is recommended for the connection is XXX.XXX.137.1. As you can see in the first image, Synergy is configured with the recommended address but is not connecting. But there is another address (marked
    1 point
  46. We're changing drag and drop to "coming soon" on our website, as of the 2.0 release. We will be re-writing this feature in 2.1 (due early next year). Because of recent OS updates, this feature has stopped working properly for a lot of users. If you purchased Synergy because of this feature and need a refund, please email us: [email protected]
    1 point
  47. I don't know what other thinks about, but in my opinion Synergy 2 is a step backwards regarding configuration-ability and stability. Dependence: Because of the dependency of the running cloud services (see several threads here, when the cloud service is offline). If your internet connection gets lost for whatever reasons, or you have any network issues because of a broken switch, you can't continue using Synergy 2 anymore? When using Synergy on multiple machines I want to use it anywhere and anytime in every situation (if I have internet access or not). Restricted network: In
    1 point
  48. I had the same problem but it was self-inflicted. I corrected the IP address in "Interface" in "Edit>Settings" to fix it. http://symless.com/forum/viewtopic.php?f=19&t=917&p=2750#p6389
    1 point
  49. I'm also having the same issue. It appears there's a bug in the Synergy GUI that doesn't save the hostname. I've worked around it by editing the file: ~/Library/Preferences/com.http-synergy-project-org.Synergy.plist and adding the key / value pair: <key>serverHostname</key> <string>SERVER IP ADDRESS</string>
    1 point
×
×
  • Create New...