Sign in to follow this  
Joel Walsh

Pro Tools on windows client problems with keyboard

0 posts in this topic

Server : Mac OSX 10.11.6

Client : Windows 7 Enterprise

Synergy : not using SSL , Server is set to re-map windows and control keys.


Pro Tools application is running on the client (Windows 7). Normal desktop applications work fine. With Pro Tools running the mouse works but the keyboard has limited functionality with the 'alt' key and 'windows' key not responding as expected or in some cases at all. Even some basic key commands for example hitting 'E' on the keyboard doesn't work at all. Again switching back to notepad app in windows the keys work fine.


Pro Tools is one of the only applications I know of that uses the windows key , mapping it to special short cut commands. I suspect Pro Tools is looking for some low / root level connection to the keyboard in the Windows system that Synergy doesn't make available.


Works fine on Mac Server to Mac Client connections I have tested it at home works as expected no issues.


Why this is significant : Pro Tools on PC is generally regarded as the 'ugly duckling' compared to the same application running on the Mac OS. About 90% of professional users have committed short cut commands to muscle memory based on the Mac keyboard layout. When these (90%) users try and work on Pro Tools for Windows the key commands are fundamentally changed immediately blocking productivity. Using synergy could be an excellent solution (if it worked:) ). With synergy running on a Mac laptop users could easily plug into the existing network, serve the Mac keyboard using Synergy to the windows client, set server option to re-map the control and windows keys all with no impact on the existing windows keyboard commands / setup.


Any chance you can have the team look into this ? I know this is a pretty edge case but I've got my fingers crossed. If you can get it working I'm confident you would see some Pro Tools users (cursed with Windows workstations) happily buying copies of Synergy.



Share this post

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
Sign in to follow this