client connection is flaky

3 posts in this topic

I am new to Synergy having just bought it and set it up today.  My server is a Windows 10 desktop PC named 'Alien', and the client is a Windows 8 laptop named 'Laptop' (connected to a docking station).

When I first installed it, everything worked on the first try.  My laptop is even connected to a VPN for my work and that's not causing a problem.  This is so perfect and I love it!  But it didn't last...

After a few hours of using it with no problems at all, I rebooted the desktop PC that acts as the server (because it nagged me about windows updates).  Then my problems started.

First my client can't find the IP address of my server by its name Alien.  To work around this, I put the IP address instead of the name Alien.  I feel like I fixed this problem weeks ago to enable my wife's laptop to download files off this machine, but I can't remember what I did... something about making Alien discoverable on my home network?  I'm not sure and I can't find it.  IIRC I set up my router to always give Alien the same IP so this should be OK, hopefully.

Now my client can try to connect, but it always times out.  I disabled my firewall, turned off my VPN, stopped and restarted the synergy service, and I can't figure it out.  The client is just stick timing out.

After poking at the options in Synergy and the control panels on both machines for about an hour, I ran out of time and had to leave for a few hours.  When I came back, the Synergy log on the server said it was connected.  I wonder how it fixed itself??  but my laptop was locked on the lock screen, and wouldn't respond to ctrl+alt+del to login...

So I opened the laptop and used the built-in keyboard to login.  Now I see that Synergy is working great again.

I tried to see if it can connect to Alien by name instead of IP, and it can.

I found the Synergy FAQ about ctrl+alt+del and fixed my group policy so I can ctrl+alt+del to unlock the lock screen on my laptop via synergy...

Immediately after applying the group policy change, the Synergy connection died.  And it can't find the IP address for Alien again.

I changed the client to connect to the server by IP address, and now it's timing out repeatedly.

I gave up and plugged my physical keyboard/mouse back in, lamenting my lost desk space.

"Connection timed out" is not very helpful information.  How can I even troubleshoot this to find more information?  Is it the client, the server, or the router blocking something?  I feel like probably some security layer is dropping the network requests somewhere, which is why the connection is always timing out.  But it initially worked with no problems when I first installed it, and it started working again on its own for no apparent reason, so where is the intermittent behavior coming from?  I could understand windows updates and a reboot messing something up, but for it to start working again on its own during hours of inactivity makes no sense.

I suspect my router.  The laptop is on wifi and maybe it's dropping/resuming its connection sometimes which causes Synergy's connection to be interrupted and broken?  Is that plausible?  I have an ethernet cable coming tomorrow to plugin the laptop's docking station to a wired network connection so maybe that will help?

Thanks in advance for any advice you can offer, I would really appreciate it!

Share this post

Link to post
Share on other sites

On the laptop (the client) I turned my wifi off and back on again and that fixed it for now (which in hindsight seems really obvious). Synergy is connected again. I'm hoping that the only problem I'm having is flaky wifi and that using an ethernet cable instead of wifi will be a permanent solution.

Share this post

Link to post
Share on other sites

I hit ctrl+alt+del to open the task manager on the client. Big mistake. At first the ctrl+alt+del screen came up on the server instead, and I thought OK that makes sense, but then as a delayed reaction it also popped up on the client.  At that point, the client disconnected from the server and has never been able to reconnect.  Disconnecting/reconnecting wifi didn't fix it this time.  The client can't get the IP for my server's name Alien again.

When I unlocked the client, I noticed that my server's antivirus firewall notified me that it had detected and blocked a port scan (4 times actually) which I assumed was probably coming from the Synergy client.  I completely disabled the firewall at that point, but I haven't been able to re-establish the connection.

Share this post

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now