Jump to content
Get Synergy | Open a support ticket
Symless Forums
DiegoVelez

Server is disconnecting client

Recommended Posts

DiegoVelez

Hello, I have 1 server and 1 client, the server is a MacOS version El Capitan, and the client is a linux machine with Fedora 24

When connecting the Fedora machine it gets disconnected automatically and retries again forever. here is the log

[2017-05-19T14:24:09] NOTE: started server, waiting for clients

2017-05-19 14:24:09.897 synergys[4739:448889] starting cocoa loop

[2017-05-19T14:24:10] NOTE: accepted client connection

[2017-05-19T14:24:10] NOTE: disconnecting client "linux"

[2017-05-19T14:24:10] WARNING: unrecognised client name "linux", check server config

[2017-05-19T14:24:10] NOTE: client "linux" has disconnected

[2017-05-19T14:24:11] NOTE: accepted client connection

[2017-05-19T14:24:11] NOTE: disconnecting client "linux"

[2017-05-19T14:24:11] WARNING: unrecognised client name "linux", check server config

[2017-05-19T14:24:11] NOTE: client "linux" has disconnected

[2017-05-19T14:24:12] NOTE: accepted client connection

[2017-05-19T14:24:12] WARNING: unrecognised client name "linux", check server config

[2017-05-19T14:24:12] NOTE: disconnecting client "linux"

[2017-05-19T14:24:12] NOTE: client "linux" has disconnected

[2017-05-19T14:24:14] NOTE: accepted client connection

[2017-05-19T14:24:14] WARNING: unrecognised client name "linux", check server co

[2017-05-19T14:24:14] NOTE: disconnecting client "linux"

nfig

[2017-05-19T14:24:15] INFO: stopping synergy desktop process

I use the basic server config which is Configure Interactively,  so I don't have any cofiguration file or anything else.

I have attached a screenshot of the server configuration

 

For the client I have the default config, it automatically detects the server and it is doing that, but for some reasson the server keeps restarting the connection

 

Captura de pantalla 2017-05-19 a las 2.55.14 p.m..png

Share this post


Link to post
Share on other sites
Paul Suarez

You'll need to check the Server Configuration on your server and check if you have added a monitor and named it "linux." You can also refer to this knowledge base article for the proper initial configuration.

Share this post


Link to post
Share on other sites
Tad75

I have just bought and installed Synergy basic, and I have the same mentioned problem, but an iMAC is my server, and the client is a Win10 PC.

 

I cannot read the file...why?

Share this post


Link to post
Share on other sites
Sruk

Have you tried changing ports on both client and server. That helped me

Share this post


Link to post
Share on other sites
orob
Posted (edited)

So I went through about a day to get this work, everything from making sure I didn't have a double NAT setup by properly configuring my Fios+Nighthawk router - all the way to doing a fresh install via the terminal for both machines. What ended up working was changing the port to 27010 on both machines, making sure I restart Synergy after making any options changes, and finally - here's the noob kicker - realizing you had to drag a fresh computer icon from the top right into the "configure server" grid if you change your network settings.

*The last step might be the only one needed. Totally not intuitive, but now I'm up and rocking. 

Here are the settings for each below. If someone smarter than me thinks I'm compromising my network please let me know and I'll redact what needed. Trusting you guys here...

Client

Underlined "Settings"
image.png.544b8f852003ca2522418633994a4433.png

image.png.1cf9bffab4b4590cae836578f148a2f6.png

 

Server:

image.thumb.png.ad47089b93532497f29638ec32e8a566.png

image.thumb.png.365733aafb2decde66a9ee9388e77fec.png

image.thumb.png.dc6f7879f84ed5d1ea50a15c5cd4aa69.png

 

 

 

 

 

 

 

 

Edited by orob

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...