Connects but no mouse or keyboard function on client

3 posts in this topic

Using Windows 7 Pro w/SP1 64-bit on both systems.  I also have dual monitors on the client system and a single on the server. - I am getting the log messages on both the server and client sides saying "entering screen" and "leaving screen" that works but I do not see the mouse and cannot type on client with server side keyboard nor paste the buffer even though the log says clipboard was updated.  Any suggestions?

Share this post

Link to post
Share on other sites

Please provide more details about your machines (OS, 32/64 bit, Synergy version installed, connected to the network via Ethernet or Wi-Fi, specify which one is the server). Also, post a screenshot of both machine's Synergy interface and the Server Configuration interface on your server machine.

Share this post

Link to post
Share on other sites

Solved the issue:

  • Running Win 7 Pro SP1 64-bit on both client and the server machines
  • Both machines connected to Ethernet, no wireless in the path (This shouldn't matter, but could effect performance)
  • Client side is connected to VPN (No split-tunneling allowed)
  • Client points to Global IP address of Cisco ASA-5506 firewall where client and server machines are located
  • Firewall provides port forwarding of TCP Port 24800 traffic to the private IP address of the machine running as Synergy Pro server (See attached Image)
  • Running synergy-v1.8.8-stable-25a8cb2-Windows-x64 on both systems
  • Setup works amazingly well, supports dual monitors, very fast, it's like one big system now!!!

My problem was that I had loaded the client on a machine that I was connecting to via RDP. (remote system that I wanted to control/Red X on image)  I needed to load the client on the machine with the keyboard and mouse I wanted to eliminate. (local machine) As soon as a did this and reconfigured the machine name I was all good, everything works as it should.

Now it makes sense why the server mouse and keyboard could not control that remote system, because the remote systems keyboard and mouse were disabled during the remote session, and using the keyboard and mouse on the system that I launched the session from.  When the client was loaded on the machine I was launching the session from the issue was solved.

Synergy Pro Corp VPN Topology

I hope this helps someone else!

  • Like 1

Share this post

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now