Sign in to follow this  

Building on Windows

0 posts in this topic

By day I'm a C#er so i'm a little out of my comfort zone and I'm following the compile instructions ([url][/url]) but have got stuck having installed all the dependencies (although I already had Wix 3.9 installed not the 3.8 suggested - but I don't get as far as using Wix) hm conf -g1 (or any of the following options) responds with: [quote]Mapping command: conf -> configure cmake version 3.2.2 CMake suite maintained and supported by Kitware ( Generator changed, running setup. Running setup... Removing build/CMakeCache.txt, since generator changed. Setup complete. Entering dir: build CMake command: cmake -G "Visual Studio 9 2008 Win64" .. -- The C compiler identification is unknown -- The CXX compiler identification is unknown CMake Error at CMakeLists.txt:39 (project): No CMAKE_C_COMPILER could be found. CMake Error at CMakeLists.txt:39 (project): No CMAKE_CXX_COMPILER could be found. -- Configuring incomplete, errors occurred! See also "D:/LocalVcs/Synergy/build/CMakeFiles/CMakeOutput.log". See also "D:/LocalVcs/Synergy/build/CMakeFiles/CMakeError.log". Going back to: D:\LocalVcs\Synergy Error: CMake encountered error: 1[/quote] hm genlist responds: [quote]1: Visual Studio 10 2: Visual Studio 10 Win64 3: Visual Studio 9 2008 4: Visual Studio 9 2008 Win64 5: Visual Studio 8 2005 6: Visual Studio 8 2005 Win64[/quote] ...but I've also got a full version of Visual Studio 2013 installed. [url][/url] suggests for CMake 3.2.2 I should be using VS 2013 which is the version installed but genlist doesn't find it. I've got VS2013 Premium installed and C++ was included in the options installed. I've tried (just for the sake of it) every hm conf -gX option, all respond as above. Update: so using the CMake GUI I've got it to build using VS12-2013 into a build subdirectory. I can open the solution generated in that build subdirectory and things looked sensible enough but when I build I get 96 errors: [quote]Error 24 error C1189: #error : The C++ Standard Library forbids macroizing keywords. Enable warning C4005 to find the forbidden macro. C:\Program Files (x86)\Microsoft Visual Studio 12.0\VC\include\xkeycheck.h 250 1 arch [/quote] This should have been fixed by [url][/url]? Update 2: So I made the change proposed to fix #4388 referenced above adding [b]/D_XKEYCHECK_H[/b] to [b]CMakeLists.txt[/b] and I get a successful build of the sln. [b][u]The Question:[/u][/b] I'm hoping to get this working on a TeamCity build configuration so having to rely on the CMake GUI isn't ideal. Any suggestions why the hm conf -gX won't work and hm genlist doesn't find the VS 12 2013 installed - even though it seems to be working with the CMake UI? After getting this far I've tried running "hm package win" to generate the installer but get [quote]D:\LocalVcs\Synergy>hm package win Mapping command: package -> dist Error: global name 'name' is not defined[/quote] Close but no cigar... any suggestions on where I've gone wrong appreciated!

Share this post

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
Sign in to follow this