heath600

Cant get past Sign in with Symless Page

47 posts in this topic

I'm using a VPN in my router. It did not allow me to login then randomly it did, now I have no issues logging in, however the software doesn't actually seem to work. It shows both my systems but doesn't allow the mouse to roll off one screen onto the other.

I'm not going to refund the software as I've enjoyed Synergy for many years (I bought v1) and I'm happy to support its continued development. Also I'm aware v2 is still beta however I feel the release date of November 2017 is fantasy, the software feels many more months away from usable in my opinion as a software developer myself.

Share this post


Link to post
Share on other sites
1 hour ago, Onoitsu2 said:

I wonder if you, or any others here are using a proxy of any kind, even one built into the router that is forced for all browsing could cause issues, as it would report that device's IP not the system itself's.I was using my DD-WRT router with its adblocking and just toggled it on to test it in a VM, and that provided me the same message on it. Just a thought there.

I would have to say that's definitely possible as I'm attempting to use the app from my work's corporate network (though both of my computers are on it and one is working). I guess I can try to bring one home over the weekend and use my home network instead to see if that helps.

Share this post


Link to post
Share on other sites

@JCY @ribcakes @Deviation

If you're having problems getting past the login screen please post the URL of the the login confirmation page that opens in your browser. The IP mismatch error happens when the your IP address as seen by our cloud server differs between the Synergy client and your web browser. This is a security measure I put in place to prevent session hijacking, but can also happen if, for instance, your web browser is configured to use a proxy but Synergy is bypassing it.

Share this post


Link to post
Share on other sites
1 minute ago, Andrew Nelless said:

@JCY @ribcakes

If you're having problems getting past the login screen please post the URL of the the login confirmation page that opens in your browser. The IP mismatch error happens when the your IP address as seen by our cloud server differs between the Synergy client and your web browser. This is a security measure I put in place to prevent session hijacking, but can also happen if, for instance, your web browser is configured to use a proxy but Synergy is bypassing it.

My work uses load balanced network connections so every internet based connection I make is randomised. Is this going to affect general usage of Synergy or just the initial account linking?

I at present can login but I cannot get the software to work between my systems, it detects my computers but doesn't allow mouse movement between screens.

Share this post


Link to post
Share on other sites
Just now, JCY said:

My work uses load balanced network connections so every internet based connection I make is randomised. Is this going to affect general usage of Synergy or just the initial account linking?

This won't effect general usage, just login. You seem to know a bit about this randomisation. I assume this is a NAT configuration that takes in to account source port when selecting an external IP?

Quote

I at present can login but I cannot get the software to work between my systems, it detects my computers but doesn't allow mouse movement between screens.

Does the GUI show both of your screens with an animated progress bar? try hitting the ` key (to the left of the 1 key on most keyboards) to reveal the logs on each machine.

Share this post


Link to post
Share on other sites
13 minutes ago, JCY said:

My work uses load balanced network connections so every internet based connection I make is randomised. Is this going to affect general usage of Synergy or just the initial account linking?

 

6 minutes ago, Andrew Nelless said:

This won't effect general usage, just login. You seem to know a bit about this randomisation. I assume this is a NAT configuration that takes in to account source port when selecting an external IP?

Sounds like it is not so much NAT, as a binding of 2 actual internet connections into one network. Is often used as a lower cost to get better throughput on things, since it is running parallel to each other, and can go faster than simply upgrading the primary connection speeds, or upgrades may not be available. Often those should report 1 IP address however if configured properly. https://www.youtube.com/watch?v=tqbnjgbtDl0&t=505s shows this in practice and explains the theory of how it should work in best case scenarios.

 

Share this post


Link to post
Share on other sites
18 minutes ago, Andrew Nelless said:

This won't effect general usage, just login. You seem to know a bit about this randomisation. I assume this is a NAT configuration that takes in to account source port when selecting an external IP?

Does the GUI show both of your screens with an animated progress bar? try hitting the ` key (to the left of the 1 key on most keyboards) to reveal the logs on each machine.

It is performed by NAT yes. New connections use one of the load balanced internet connections at random. Traffic destined for the same port as the packets went out to come back properly to the same IP. So all services, games, websites all work. Just every brand new request (like a new page refresh) uses a randomised connection to the internet. At work we have three. This is all done on the pfSense router at work and not done on our local machines.

But it can cause issues with authentication schemes that require the IP to be the same. To be honest since the site is using HTTPS I don't think the IP lock is necessary but that's just me, would be hard to steal the session in transit with the certificate in place for your domain unless I as a customer have installed a root cert on my own system at which point my computer is compromised anyway.

As for the log I have two for you, this is my desktop system: https://synergy-logs.symless.com/2017-09-22/1495-2017-09-22T23-26-31.log and this is my laptop: https://synergy-logs.symless.com/2017-09-22/1495-2017-09-22T23-27-10.log

The situation is like this: On my desktop and notebook only my Desktop called RAMPAGE in the log is showing as green while the MacBook Pro is not. Perhaps this is caused by yet more load balancing issues as the log is referencing multiple IP Addresses for my desktop system and in this case it does have multiple NIC's to our file server (SMB 3.0 supports the binding of multiple network interfaces for higher throughput).

Also just as aside, Synergy 2 does not yet offer a way to quickly turn it off or on and it doesn't have a way to customise the keys, will this be coming in the future? - To be honest I really need those features.

Final thing I wanted to say, when I run Synergy v1.8.8 on my Laptop and the 2.0.0-beta4 on my desktop, it works fine, I can mouse across to my laptop from my desktop without any issues.

5 minutes ago, Onoitsu2 said:

 

Sounds like it is not so much NAT, as a binding of 2 actual internet connections into one network. Is often used as a lower cost to get better throughput on things, since it is running parallel to each other, and can go faster than simply upgrading the primary connection speeds, or upgrades may not be available. Often those should report 1 IP address however if configured properly. https://www.youtube.com/watch?v=tqbnjgbtDl0&t=505s shows this in practice and explains the theory of how it should work in best case scenarios.

 

That is not how it is at my work no. We just have three seperate internet lines and it's setup in a load balanced configuration where requests are sent to different connections randomly. Network connections with high latency or packet loss no longer handle connections. This is a built in feature of pfSense.

Edited by JCY
  • Like 1

Share this post


Link to post
Share on other sites
4 minutes ago, JCY said:

Final thing I wanted to say, when I run Synergy v1.8.8 on my Laptop and the 2.0.0-beta4 on my desktop, it works fine, I can mouse across to my laptop from my desktop without any issues.

Interesting that you can have it work with an older. I could not get it to work at all like that in my testing, had to update my headless server to v2 beta even to continue using it with my main desktop.

Share this post


Link to post
Share on other sites

@JCYit looks like your desktop (RAMPAGE) is able to connect to your Mac, but your Mac is unable to connect to RAMPAGE. Is RAMPAGE firewalled? Disabling the Windows firewall would be my first suggestion.

As far as logins go, I can see that you have successfully logged in 3 times, all from the same IP address. Unfortunately we're not logging failed logins due to IP mismatch, I've made a note to do that.

The IP restriction actually comes from when we were exploring third party social login. The risk isn't interception of anything going over the wire, but rather someone else sending you a 'login with symless' link (perhaps behind a redirect) and getting you to click it. Doing so would activate their session under your account and let them mess with your configuration. This is known as a phishing attack. If you want to nerd out on this further, OWASP makes comment on this approach https://www.owasp.org/index.php/Session_Management_Cheat_Sheet#Binding_the_Session_ID_to_Other_User_Properties

@Onoitsu2 This is possible because Synergy Core (as it is now called) is still compatible between v1 and v2. As long as your v1 install has been (manually) configured to use the appropriate screen names, everything will just work.

Share this post


Link to post
Share on other sites
2 minutes ago, Andrew Nelless said:

 This is possible because Synergy Core (as it is now called) is still compatible between v1 and v2. As long as your v1 install has been (manually) configured to use the appropriate screen names, everything will just work.

Interesting, I may have to play with mixing and matching things so that I can still keep using v2, I love it, but not all of its quirks.

Share this post


Link to post
Share on other sites
3 minutes ago, Andrew Nelless said:

@JCYit looks like your desktop (RAMPAGE) is able to connect to your Mac, but your Mac is unable to connect to RAMPAGE. Is RAMPAGE firewalled? Disabling the Windows firewall would be my first suggestion.

As far as logins go, I can see that you have successfully logged in 3 times, all from the same IP address. Unfortunately we're not logging failed logins due to IP mismatch, I've made a note to do that.

The IP restriction actually comes from when we were third party social login. The risk isn't interception of anything going over the wire, but rather someone else sending you a 'login with symless' link (perhaps behind a redirect) and getting you to click it. Doing so would activate their session under your account and let them mess with your configuration. This is known as a phishing attack. If you want to nerd out on this further, OWASP makes comment on this approach https://www.owasp.org/index.php/Session_Management_Cheat_Sheet#Binding_the_Session_ID_to_Other_User_Properties

@Onoitsu2 This is possible because Synergy Core (as it is now called) is still compatible between v1 and v2. As long as your v1 install has been (manually) configured to use the appropriate screen names, everything will just work.

I didn't think my computer had the Windows firewall on but it does. I will try without. I understand now why you would use the IP as part of the session token, thank you for explaining.

I was wondering can you elaborate slightly about whether v2 will gain some kind of "advanced" options menu where we can specify things manually like v1? - I know the marketting material surrounding v2 is that it's meant to be extremely simple to use for the novice but obviously those of us who already were using v1 are used to this level of complexity and have customised our setups considerably.

For example right now there's no stop/start button in the UI, will this come later? - I often have to disable Synergy when I start certain full screen games because the mouse doesn't stop at the edge causing the game to minimise if I drift off screen etc

Thanks.

Share this post


Link to post
Share on other sites

@JCY Yes, a start/stop button or some such equivalent functionality has been penciled in for the next beta.  How would you like it to work?

1 minute ago, JCY said:

I often have to disable Synergy when I start certain full screen games because the mouse doesn't stop at the edge causing the game to minimise if I drift off screen etc

Note, you can still use Scroll Lock to lock your cursor to the current screen, which might help resolve this.

Share this post


Link to post
Share on other sites
4 minutes ago, Andrew Nelless said:

@JCY Yes, a start/stop button or some such equivalent functionality has been penciled in for the next beta.  How would you like it to work?

Note, you can still use Scroll Lock to lock your cursor to the current screen, which might help resolve this.

That's great regarding the start/stop button. I would just like it by default to connect when the software starts up but then you can click like a stop or pause button to just make Synergy disconnect from your other computers until you start or unpause it. Also I wasn't aware of the Scroll Lock thing, good to know.

Also you guys will be offering the ability to customise keys and things? I always remap the CMD key to CTRL for my Mac so I can use CTRL + C and CTRL+ V instead of Super + C and Super + V. It's just more natural for me since I'm using my PC keyboard to type to my Mac to keep the keyboard usage consistent.

Thanks again.

Edited by JCY
  • Like 1

Share this post


Link to post
Share on other sites

Key remapping is coming to 2.0 for sure. I think at first we're planning on just doing the typical Mac/Win remapping automatically, and then add a properly thought out UI for remapping later.

I've changed our server implementation do more aggressive logging, so we can monitor the login situation more closely. This hasnt been pushed live yet, but will be in place for beta5.

Share this post


Link to post
Share on other sites

Looks like Synergy 2 is trying to use a different proxy than my browser, so I am stuck with the IP Mismatch problem.

 

Any suggestions?

Share this post


Link to post
Share on other sites

@Andrew NellessI also have a similar issue which I wrote about in earlier versions and sorry to somehow hijack this thread but it seems that you are the expert and can help. My issue is that when I click on login, the account page opens in the browser but nothing happens in synergy window. I'm using firefox but also set chrome as default browser to test this and get the same behavior, any ideas?

Share this post


Link to post
Share on other sites
19 hours ago, Ballantin said:

Looks like Synergy 2 is trying to use a different proxy than my browser, so I am stuck with the IP Mismatch problem.

 

This is a known bug, it'll probably be fixed in beta6.

Share this post


Link to post
Share on other sites

I confirm this issue behind our corporate proxy. Using available beta4.

Recommendation: While you can try to fix this, there will always be some corner case where it won't work - you should provide alternative way of activation, e.g. email confirmation and code copy-paste.

Thanks, otherwise it looks cool :-)

  • Like 1

Share this post


Link to post
Share on other sites

Agreed about alternative activation. To be honest why not just have us login through the application itself? That's how practically all other software does it.

Share this post


Link to post
Share on other sites

Have you tried running synergy from tsocks? That at least let me login, then I see different issues.

Share this post


Link to post
Share on other sites

Hello,

I will need to be able to activate offline, as I have a number of systems that are running Synergy that have NO internet access whatsoever, and never do.  I am supporting v2, and hope that there will be the ability to activate with a key or something offline or I will be stuck and unable to use the new version at all.

Share this post


Link to post
Share on other sites
On 14/10/2017 at 3:19 PM, Zucky said:

I am supporting v2, and hope that there will be the ability to activate with a key or something offline or I will be stuck and unable to use the new version at all.

We do plan on adding this, but it might not be until 2.1 (due Q1 next year).

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now