Jump to content
Get Synergy | Open a support ticket
Symless Forums
Dakattack

Keyboard not working - Mac Server, Windows Client

Recommended Posts

Dakattack

Using the latest build of synergy for both macOS and Windows 10, I can only get my Macbook cursor movements to send to the Windows client, but my Macbook keyboard doesn't send anything to the windows machine with the exception of the command key. When I press the command key, the windows start menu opens. But any other command related shortcut (Command+V for example) will paste text on the Macbook even when my mouse cursor is controlling the Windows machine.

 Macbook Pro 15 inch, 2017: macOS Sierra 10.12.6

Windows 10 Home

Both using Synergy 1.8.8

Share this post


Link to post
Share on other sites
StevenL

Hey Nick, 

I'm experiencing the exact same issue (inc only command key working), did you find a fix for this?

Synergy 2.0.4 Stable

Mac OS Seirra 10.12.6 ,  MacBook Pro (13-inch, 2016, Two Thunderbolt 3 ports)

Windows 10 Pro

Share this post


Link to post
Share on other sites
JeffreyC

I am seeing this as well (no keyboard except command key)

Synergy 2.0.4

Mac Pro / 10.13 , SurfaceBook 2017 / Windows 10 Pro

 

 

Share this post


Link to post
Share on other sites
RandomUser363

I am also seeing this behavior. 

Synergy 1.8.8-stable-25a8cb2

Mac Sierra 10.12.6, Windows 10 Pro

Share this post


Link to post
Share on other sites
Bold Derek

Hi all I am having the same issue.  Is there a work around for this?  High Sierra 10.3.3 and Windows 10 (latest). Mouse works but Keyboard is a no go.  

Share this post


Link to post
Share on other sites
RandomUser363

User support was zero help for me. Just told me to upgrade my version which is not the problem. Issue is coming because of permissions to the application.

I found a work around by doing the following in the terminal of the Mac server system:

sudo open -a Synergy

Sometimes the keys get messed up and won't go the the windows client again, just close it out and re-issue the command in the terminal. So far this has worked for me.

 

Share this post


Link to post
Share on other sites
Tony Trinh

I have the same issue. I solved this problem by changing Keyboard Preference "Use F1,F2, etc. keys as standard function keys" and it worked. However, It is not working after a bug that make my mouse curser unable to move from the centre of the monitor. I restarted the program on both PC and Mac, and my solution is not working since then ( the mouse is still working fine and only Command key is working ). My synergy version is 1.8 and I believe the its not the solution since JeffreyC still has the same problem. Thanks

Share this post


Link to post
Share on other sites
BenjaRiley

Same here, it's driving me nuts. I'm running 1.8.8-stable-c30301e..

Share this post


Link to post
Share on other sites
JeffreyC

While not the preferred solution; I gave up and purchased Logitech Flow keyboard+mouse.

Share this post


Link to post
Share on other sites
BenjaRiley
23 minutes ago, JeffreyC said:

While not the preferred solution; I gave up and purchased Logitech Flow keyboard+mouse.

The funny part it was working great last week. I will remove the software and reinstall and see if anything changes. I didn't try mac to mac, the issue I'm experiencing is mac to pc.

Share this post


Link to post
Share on other sites
BenjaRiley

Looks like it is working again. Keyboard is working just fine today. Not sure what happened. 

Share this post


Link to post
Share on other sites
Tony Trinh
9 hours ago, BenjaRiley said:

Looks like it is working again. Keyboard is working just fine today. Not sure what happened. 

What did you do ? Reinstall Synergy? Update Windows? I reinstall it today but no hope :((

Share this post


Link to post
Share on other sites
Tony Trinh

Hi, Just for update. After update from 1.8.0 stable to 19.0 stable. Everything work normally now :)

  • Thanks 1

Share this post


Link to post
Share on other sites
thinkski

I had this same issue. Mac OS X 10.14 server. Windows 10 client. Both running version 1.10.2. Resolved the issue by unchecking the Synergy box in the Accessibility menu within Security & Privacy within System Preferences, rebooting, and then re-checking the box.

  • Thanks 1

Share this post


Link to post
Share on other sites
Daniel Ralph

thinkski's solution worked briefly for me. But after only a few minutes of use, the keyboard stopped going through to the client from the host. Mouse continues to work normally.

(Mac -> Mac, both running 1.10.3-stable-ca35737a, happily connected with TLSv1.3 over a reliable connection.)

Share this post


Link to post
Share on other sites
Alexey Pilyaev

Hello @Daniel Ralph

Please, could you email us [email protected] with the information on your current Synergy version and your OS's version?

Share this post


Link to post
Share on other sites
GeoffreyK

I'm having the exact same problem.  Yes I have followed the instruction for fresh re-install on both server and client.  Server side is iMac running 10.13.16 and client side is Mac Mini running 10.15.5.  Don't ask me why I am running different versions of OS X.  I read through all the posts about SecureInput stuff and some apps intercepting keystrokes etc.  And I thought going with "Pro" with TLS encryption might help assuming the encryption will hide the messages etc.  Silly me.  It didn't help at all.  I just wasted $9.  _shrug_

I'm running:

Version:  1.11.1-stable-55ec3105

Build Date: Mar 19, 2020

Any advice?  Or should I go with another solution?

Share this post


Link to post
Share on other sites
QHoster

Same problem here, I try to use this several time over the past two years since bough. Never done a cent of actual work. Paid like $29 for this, useless. Should have donated them.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...