Jump to content
Get Synergy | Open a support ticket

Synergy on Client Mac Lagging


Recommended Posts

So I'm running my Windows machine as my server, and my MacBook Pro as my client. While on my Windows machine everything works fine, but on my MacBook Pro, whenever I go to open a new program or sometimes just when I am typing on something, everything becomes extremely laggy, sometimes to the point of being non-usable. I also will receive random stutter sometimes on my MacBook Pro for seemingly no reason whatsoever.

I am currently running Synergy 1.9, found in the link below, but I only switched to 1.9 after not being able to find a solution to this problem on Synergy 1.8.8. I am running my MacBook Pro over wifi and my Windows machine is running on ethernet.

Is this kind of lag I am experiencing considered normal, or is there something I might need to fix?

 

Link to post
Share on other sites
  • Replies 53
  • Created
  • Last Reply

Top Posters In This Topic

  • deegee

    5

  • Nick Bolton

    5

  • vikemosabe

    3

  • DalsieQ

    2

Top Posters In This Topic

Popular Posts

I have also had nothing but lag when I try to use the mouse from my Win10 PC on my MacBook pro.  Has anyone gotten an answer about this other than "Install the latest version"?  Cause I literaly just

  • 2 weeks later...

Hi Guys.

I have the same issue. From Ubuntu (server) to macOS (client). Starting the connection initially everything runs smoothly, but 2min later when the mouse/kb moves to the client I get lags and jumps on the client mouse movements and keyboard typing none stop. The mouse jumps like it's stuck and suddenly realizes it has to move now lol, same with the keyboard. 

Symptoms:

1. Mouse remains in place while typing.

2. When you start moving the mouse - it doesn't start moving immediately, it only jumps to the movement point about 1sec after, then moves with the mouse movement with laggy jumps every few seconds. 

3. keyboard typing types a few letters then lags, then fast-types a few letters.

 

My Current versions in use:

macOS: 1.9.0-rc3-<loooooong_number>

Ubuntu: 1.9.0-rc3-09ff581

Link to post
Share on other sites
  • 3 weeks later...
  • 3 weeks later...
  • 1 month later...

Same issue here, didn't have this problem with v1.

 

Server side is Win10, client side is 2012-MBP.

 - v1 I used with Win10 for server side, and an 09-MBP and never had any lag issues, not of this magnitude anyways.

 

Now it is almost unusable when it comes to the mouse. It is so frustratingly annoying, I am genuinely upset I had to pay for this upgrade when I already owned Pro of v1.

 

All my versions are up to date.

Link to post
Share on other sites
  • 3 weeks later...

Same issue here...I am only allowed to install 1.8.8 which has some very laggy mouse movements on my client MBP from my host MBP.  I just upgraded this morning and was only able to download 1.8.8-stable.  

 

I have tried disabling SSL but that doesn't seem to matter...anything I should do or try?  Pretty unusable as it is.

Link to post
Share on other sites
Marco Williams

I am also having this issue.   Was using 1.8  and it was laggy (not sure why),   Spent 49 bucks on the upgrade, and 2.0 is just as Laggy.   This only seems to effect the mouse.   It is intermittently laggy,  meaning sometimes it frees up and allows me to move pretty fluidly then the next second it is laggy again.

Is there a fix for this?  What info do you need from me to understand the root cause of the problem?

Link to post
Share on other sites

I'll throw my case in here as well. MBP Touchbar 2017 -> MBP Touchbar 2017 very bad lag, currently unusable. Every 2-3 minutes I get a smooth 3-4 seconds of mouse action.

Link to post
Share on other sites

I have also had nothing but lag when I try to use the mouse from my Win10 PC on my MacBook pro.  Has anyone gotten an answer about this other than "Install the latest version"?  Cause I literaly just got synergy today, so i have all the latest versions and everything and still experince lag that makes it unusable.

  • Like 1
Link to post
Share on other sites

Same here folks. Just purchased and downloaded the software. Windows 10 server and tied it to a late 2017 Macbook Pro (w/ TouchBar). Very laggy on the mac, first instance of movement lags so much that it's almost unusable. However, once the mouse gets moving, the lag disappears. Comes back the instance the movement stops. At this point, I cannot use Synergy. 

Synergy 2.0.4-stable

Edited by 5HADE
Added version of synergy software
Link to post
Share on other sites
On 1/6/2018 at 5:16 PM, 5HADE said:

Same here folks. Just purchased and downloaded the software. Windows 10 server and tied it to a late 2017 Macbook Pro (w/ TouchBar). Very laggy on the mac, first instance of movement lags so much that it's almost unusable. However, once the mouse gets moving, the lag disappears. Comes back the instance the movement stops. At this point, I cannot use Synergy. 

Synergy 2.0.4-stable

Same here. Lags 5 secs when switching win 10 to Mac. Any fix? 

Link to post
Share on other sites
  • 3 weeks later...
  • Synergy Team
Nick Bolton
1 hour ago, Nick L said:

I just purchased this and I am having lag on my 27" imac from my windows laptop.

Is it constant lag, or just when you open an app? Try closing all apps other than Synergy (some apps interfere with the network adapter).

Link to post
Share on other sites
  • 2 weeks later...
On 12/11/2017 at 10:29 AM, neumant said:

Same issue here, didn't have this problem with v1.

 

Server side is Win10, client side is 2012-MBP.

 - v1 I used with Win10 for server side, and an 09-MBP and never had any lag issues, not of this magnitude anyways.

 

Now it is almost unusable when it comes to the mouse. It is so frustratingly annoying, I am genuinely upset I had to pay for this upgrade when I already owned Pro of v1.

 

All my versions are up to date.

Still no updates, and still dealing with a major lag.

Unfortunately going to have to just uninstall until this is resolved.

Please keep us posted as I hate that I have to uninstall this program.

I will be submitting my logs from both machines through your ticket portal.

Link to post
Share on other sites
  • 4 weeks later...

Also having the same issue, for me it's constant jitter as I move the mouse on my Mac (client). Super frustrated as this issue has been around for so long now.

Link to post
Share on other sites
On 3/5/2018 at 8:45 AM, RxMarcus said:

Also having the same issue, for me it's constant jitter as I move the mouse on my Mac (client). Super frustrated as this issue has been around for so long now.

I've returned my purchase and uninstalled.  Zero communication from support about the issue or steps to resolve it.  I'm looking into hardware solutions now as this was a complete failure.  Very disappointed.

Link to post
Share on other sites
Fady Naffa
On 3/7/2018 at 3:45 AM, JD5 said:

I've returned my purchase and uninstalled.  Zero communication from support about the issue or steps to resolve it.  I'm looking into hardware solutions now as this was a complete failure.  Very disappointed.

I am doing the same.

Link to post
Share on other sites

I am using Synergy 2.0.7 and I have the same issue.  Randomly, the mouse on my Mac Book Pro High Sierra 10.13.3 client lags. I move the mouse and it's "sticky" for a second and then it starts to move.

It only seems to behave like that after leaving the mouse in a position for a certain time and it does it randomly. If I keep moving the mouse it moves almost smoothly.

It's pretty annoying, please come with a fix.

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...