Stuttering on Windows 10

2 posts in this topic

Hi everyone,

I have two Windows 10 machines that successfully connect (computer 1 is a PC, computer 2 is a Surface Book). However, everything only works okay in five-second increments. It goes something like this:

-five seconds of smooth, problem-free operation on the client side

-alternating half-second smooth, half-second unresponsive mouse movement for the next five seconds (basically stuttering)



Server experiences no problems.

Computer 1 is the host and is connected to the network by wire, while computer 2 is the client and is on wifi. I tested both on wifi with a similar result. I tested the connection in reverse, where computer 1 is the client, and computer 2 is the host, with similar stuttering on computer 1 when it was the client.

I would try putting both on wired connection, but that is not an option since computer 2 has no ethernet port.

I also noticed that the problem does not occur if the server connects before I've logged into my account on computer 2. As soon as I enter my password and the desktop loads, the mouse begins stuttering on the client side again.

I've tried disabling antivirus, firewall, etc., but it does not seem to help.

I've tried Synergy 1.8 and and the 1.9 release candidate.

Does anyone have any ideas as to what could be causing the problem? Not really sure what questions I should even ask myself regarding what software is running in the background, or if any other peripherals might be causing problems (tablet, touch screen software on the laptop, etc). Although I tried unplugging the tablet, which has caused other input issues in the past, and this did not help.

Thanks in advance.

Share this post

Link to post
Share on other sites


I have found this issue after quite a bit of poking around on different forums. It seems the culprit was Enpass. Quitting the application on the client machine removes all stuttering, and everything is silky smooth again. Anyone having issues similar to this might consider checking if they have a password manager open that might use auto fill. Figured this out after I read in another forum that someone lost keyboard/mouse inputs on the client machine after logging into LastPass.

While it would be nice if I didn't have to do this to fix the issue, it's a small price to pay for a working machine in the short term. I hope this gets resolved more permanently in the future, as it would be nice if I didn't have to quit my password manager whenever I needed to use Synergy.

Share this post

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now