Jump to content
Get Synergy | Open a support ticket
Symless Forums
MJ50

Screen saver not working on Windows 10

Recommended Posts

MJ50

I just installed Synergy server on Windows10 desktop and client on Windows10 notebook.

Everything works fine except for screensaver on both devices.

Screensaver does not turn on.

Tried powercfg but that only seems to work temporarily.

Any suggestions?

Share this post


Link to post
Share on other sites
geeksncomputers

Also same issue - Mac High Sierra as the Host and Windows 10 as the client and the Win10 screen saver will not engage. So I turn off the monitor, however if the monitor is off, Synergy will stop working on the Win10 machine. 

Share this post


Link to post
Share on other sites
Zathras42

I had the same issue but on Win7 up until 2.0.8.  Working ok since.

However, a Win7 workaround batch file may work with Win10.

synergy.bat  (create in Synergy directory)

powercfg /REQUESTSOVERRIDE PROCESS synergy-core.exe SYSTEM DISPLAY AWAYMODE
powercfg /REQUESTSOVERRIDE SERVICE Synergy SYSTEM DISPLAY AWAYMODE
pause
powercfg /REQUESTSOVERRIDE
pause

 

Edited by Zathras42

Share this post


Link to post
Share on other sites
shakana

The commands above seemed to prevent the machine from going into sleep mode. How can I just get the screen to turn off after inactivity. Synergy is preventing that. Any ideas?

Share this post


Link to post
Share on other sites
Zathras42
3 hours ago, shakana said:

The commands above seemed to prevent the machine from going into sleep mode. How can I just get the screen to turn off after inactivity. Synergy is preventing that. Any ideas?

For me under Win7 and the batch file, the screen saver comes on after a set time (20 mins), then after Windows Power Plan setting (25 mins), the monitor goes into sleep mode.

Computer still runs normally, just the monitor goes to sleep, like it should.

Share this post


Link to post
Share on other sites
shakana

I have tried it from the prompt in Windows 10. My monitor is set to 1 min before turning off and my computer is set to never sleep. My monitor still never goes off.

  • Like 1

Share this post


Link to post
Share on other sites
INPHOman
On 8/4/2018 at 6:57 PM, shakana said:

I have tried it from the prompt in Windows 10. My monitor is set to 1 min before turning off and my computer is set to never sleep. My monitor still never goes off.

Same issue here - Win10 client ignores power rules

  • Like 1

Share this post


Link to post
Share on other sites
Beat Döbeli Honegger
On 5.4.2020 at 6:40 PM, INPHOman said:

Same issue here - Win10 client ignores power rules

Interesting, I have the same problem. This thread was silent since 2018. I wonder if the problem was solved in the mean time and is popping up again or if Synergy is used more often these days because of Covid-19 home office and the problem was never solved.

  • Like 1

Share this post


Link to post
Share on other sites
Cristian Delgado

I think you're 100% right, since the Covid pandemic I've started using Synergy again. I found that disabling the "Sync Screensavers" setting allows the screensaver to kick in, but when the timer to turn off the display kicks in, the screen saver stops and the screen keeps turned on. I was going nuts uninstalling all the software I had installed recently looking for a cause, until I quit Synergy and everything came back to normal.

Share this post


Link to post
Share on other sites
Rich N9JIG

I have Synergy installed with my Mac Mini 2018 as the Server (MacOS Catalina 10-15-4) and my Intel HC-NUC as a client. Everything works fine except the Windows screen will not shut off as it did before Synergy was installed. The Mac screens go off on schedule but the Windows screen does not.

Does Synergy Support follow these forums and do they have an answer?

Share this post


Link to post
Share on other sites
jp83

Same problem, long time user of old free version.  Recently updated my Macbook Pro to Catalina 10.15.4, finally paid for personal license, and now my Win 10 PC screensaver/monitor powerdown will no longer activate.  Messed with a bunch of settings and restarting to no avail.

Share this post


Link to post
Share on other sites
Rich N9JIG

I initiated a Support ticket and they replied that they are aware and working on a solution. Until then I set my Windows monitor to one I can easily access the power button, the others are more difficult to access in my setup so they are on the Mac so that the screens will turn off properly.

Hopefully they get this resolved so we can properly use our systems.

  • Like 1

Share this post


Link to post
Share on other sites
dkt

Going in to server settings (Configure Server), then Advanced Server Settings, and disabling Synchronize screen savers, then applying that, will allow clients to follow their own sleep schedule.

Strangely, the server on Windows will not apply a display lock, but, the client will if that setting is enabled. Disabling that causes synergy to release it's lock and the screen/s on windows clients will follow the configured screen power off timer on them.

  • Like 1

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...