First impressions

4 posts in this topic

Hello, new user to the beta here. First impact was really daunting, since nothing was working and I had to change my keyboard layout to be able to see any log or anything.

Tilde is not international friendly.


Connecting a W10 and an Ubuntu desktops, it seemed there was no control over what was happening. It would not connect, (firewall on or off no difference).

Followed troubleshooting, tried different things, it didn't seem to help at all. Then it worked. Then it did not. Then it worked again. With no apparent change.

By sheer force of restarting it a number of times poking randomly at it, I managed to get Synergy working again somewhat stable so far.. I'm not even sure how. and that is not a really good experience, even for a beta.

Or so I thought.. now my ubuntu box can only be controlled by my main mouse. local controls on it work only if I move the mouse to that screen.


I'm willing to test, and I paid to test.. but this kind of lacks the tools required to do so.


Said that, I have high hopes for the future, as I've used Synergy for years and want to believe.

Some suggestions, if they weren't already mentioned:

Logs console should be visible (as in V1) by default and possibly resizeable, it's our lifeline to what's going on.

Use of keybinds available on international keyboards by default. It might be a beta, but there's no reason for having to change keymap to find the tilde key..

Have an error displayed if the service isn't running. Would really help figuring out there's something wrong. I did not realize it was not running at first.

Ability to completely disable keybinds.. Had that issue in V1 as well, I use NumLock for other things, Synergy hijacks it.. I don't want to rebind it through a config file, I want to remove it. Never used lock to screen (willingly) once in many, many years.


Over all, when I got it working, it was fine. As long as I didn't want to type on the second pc for some reason.

Just to make sure.. I understand it's early access and that there will be issues. That's why I'm giving feedback, and I'm hoping to contribute my experience to see that maybe things could become better.


Best regards!

Share this post

Link to post
Share on other sites

I'm sorry, I meant ScrollLock, not NumLock.. and I don't see an edit function for the previous post.


Share this post

Link to post
Share on other sites

I have the same experience as WoLf - except I can go from one computer to the other, but not the other way round. Then it worked (10 sec) then it didn't (5 days) then it worked (10 sec) then not etc. Since there are no settings (at least as far as I can tell) I'm not sure what to do next. Shut down, start up (repeat) doesn't really help. Both rectangles on both computers (both W10) are always green.

Share this post

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now