wunderdojo

Problem connecting to the auto-config service

146 posts in this topic

I have the same problem,my environment is

Synergy : 2.0.2 stable

OS: MacOS high sierra 10.13.1

Share this post


Link to post
Share on other sites

I had the same problem with Synergy-2.0.2-stable on my MacBook and ArchLinux, but after I setup my VPN, it just work.

I'm a chinese, so I think the Synergy cloud server is blocked by China GFW

Share this post


Link to post
Share on other sites

Same Issue here, Synergy 2.0.2 

On Windows 10 there was a problem connecting to the auto-config service

On Mac os x 10.13.1 there was a problem connecting to the background service

Both of them clean reinstalled, no change.

Tried killing synergy-config on mac osx, no change.

Any suggestion?

Thanks ;)

Share this post


Link to post
Share on other sites

Since the posts keep on coming I figured I'd follow up a week later. With everything rolled back to Synergy version 1.8 I've had zero problems using it daily in two different environments with a mix of Ubuntu and Windows machines (no Macs though). If you're struggling with v2 I'd definitely recommend going back to that version. Personally, I'd also love to see something from Nick that explains what the changes were and what the cloud configuration is supposed to do. For example, what about situations where machines are only connected to an intranet, not the internet? From what I've seen that would render v2 inoperable. 

Just to be clear, I'm a big fan of Synergy and super appreciative of the product. I'm not assuming anything other than the best of intentions on the part of the developers. But I take issue with making major changes to a product with no notification, especially when one of those changes introduces what could potentially be a security issue and definitely raises some privacy concerns. If you look at the listed "coming soon" features on their site (https://symless.com/synergy/pricing) they list a lot of things that clearly indicate a move towards Synergy functioning more like TeamViewer in terms of device management -- which could be very cool but is a very different type of offering than what it has been.

Share this post


Link to post
Share on other sites

same here version 2 is totally and utterly unusable.

 

after forking out a whole 9 dollars, this software is utter shite, will move back to synergy v1 at least that had geeky stuff to look at and settings i could check. please give up on ever thinking i will pay for another licence for version 3, plus who ever had the idea that everyone has computers connected to the internet 24/7 sheesh

Share this post


Link to post
Share on other sites

Just chiming in to say that I too have this issue, and that v2 is unusable and a total disaster.

Cloud server thing = conceptually flawed

  • Like 1

Share this post


Link to post
Share on other sites

Sorry to hear that you find Synergy 2 so incompatible with your expectations.

BTW, Synergy 2 SPARKLES in my 4 computer arrangement, autostarts and doesn't drop configuration.

I'm sure Symless can be convinced to refund your substantial investment if you ask.

Share this post


Link to post
Share on other sites

@KringleKrebs -- We get it. You love Synergy. v2 works great for you. They can do no wrong. Enough already. They released an update that is causing issues for a ton of people and they're not doing squat to address it. They continue to sell a product that they know is problematic for people without at least posting some kind of "You may run into the following..." notice. If someone is looking at this thread it's undoubtedly because they've already spent a bunch of their time trying to get it to work and Google'd their way here trying to find a solution since none is forthcoming from Symless. It's Dec. 4 already, shouldn't you be busy checking lists and seeing who's naughty and nice?

  • Haha 1

Share this post


Link to post
Share on other sites
16 minutes ago, wunderdojo said:

.... If someone is looking at this thread it's undoubtedly because they've already spent a bunch of their time trying to get it to work and Google'd their way here trying to find a solution since none is forthcoming from Symless. It's Dec. 4 already, shouldn't you be busy checking lists and seeing who's naughty and nice?

 

LOL! Ho, Ho, Ho, Yep, thanks for the comment. I work SeaWorld San Antonio and we've been really busy this season so far. As for this old (otherwise) retired guy, it's a great way to have a lot of fun and make a small amount of money for my own gift-giving.

You nailed it that I am a fan. Since what seems like decades ago.

I had my share of issues when I joined the beta testing program. But I enjoy muddling through computer problems. Having all the time in the day to troubleshoot seems to take away a little of the frustrations. 

In most of my comments, I try to add a little perspective. When one person is working on a version of Synergy and hits a wall, then that's 100% of their experience. Lots of times they jump to the assumption that the program is no good since that is their 100% experience. Perfectly understandable. I try to interject that there are (?) thousands (?) of users that are successfully using the product. The most honest way to do that is to share my own experience.

Stick with it and maybe end up with a useful addition to your SuperSystem or drop back to an earlier version that works for you. Almost all of us that started the beta program had to drop back at some point.

Either way...Merry Christmas!!

Share this post


Link to post
Share on other sites

I purchased the pro version yesterday and have found support to be responsive to my issues.  I'm waiting on a build to address issues.  It's been reported as underway.  I've not downgraded to 1.8 yet, though it's a possibility.  

  • Thanks 1

Share this post


Link to post
Share on other sites

Same issue. 

Windows 10  + Macbook Pro

Completely fresh installation, worked perfect with 1.8 , now with 2+ constantly disconnecting and tries to reconnect without anything happening.

It's nice to have a software marked at "stable", with zero buttons, menus, configuration settings, documentation on what is going on and how to configure it.

  • Like 1

Share this post


Link to post
Share on other sites

yeah.  I complained about documentation, and lack of advanced config options also.

 

  • Like 1

Share this post


Link to post
Share on other sites

I from China, I found the network in my region block the cloud server pubsub1.cloud.symless.com, that cause me with same problem as you. Hope this can help to solve.

Edited by Gates

Share this post


Link to post
Share on other sites

Same issue here on Ubuntu 17.04 x64 and Windows 10 Pro x64. I have a bad experience with Synergy 1.x, but version 2.x manages to surpass it. I was trying from beta4 to 2.0.2. And that empty window with only computer name is just killing me. How do I even suppose to know if it is loaded correctly. Not even "About" menu.

  • Like 1

Share this post


Link to post
Share on other sites

I purchase v2 as well and was excited to use it but after install I could not get it to reliably stay connected (2 machines, win10 & ubuntu 17.10). The lack of configuration options and oversimplified interface is just icing on the crap cake. 

I've gone back to 1.8 which works excellent. I've been using synergy for years and have spread the message at work but I won't be recommending any upgrades as things are today. 

I'll keep pace with new releases and hopefully things get better so I can recommend it again.

  • Like 1

Share this post


Link to post
Share on other sites

+1 to pretty much every complaint here.  I have 2 windows laptops + a mac mini with a few secondary monitors that worked together perfectly with a combination of a kvm switch, mouse without borders (for the windows machines), and synergy (to connect the windows machines with the mac when I had one of the monitors switched to the mac mini).  Once I downloaded Synergy 2, the lack of configuration options made the entire setup break even when it CAN connect to the auto-config service.  Why would you ever DECREASE the options available to a user?  Why not just tuck them away somewhere in an "advanced options" menu?   I guess I'm going to have to roll back also

Share this post


Link to post
Share on other sites

Back in September I purchased the old version. Quirky but I worked. Support was great but never got it to run without problems. So I was glad to hear about the new version. Not so glad that I had to pay again two months after having paid for the old version. If it worked it was better than the old version. But after two weeks I decided to go back to my good old KVM switch. The "Problem connecting to the auto config service" made it impossible to work productively. Just uninstalled Synergy.

Share this post


Link to post
Share on other sites

Same issue with 2.03. Beta 4 didn't allow clients to connect to each other ,but at least I could see them, now we're on 'stable', I can't even get to the auto-config service. When multiple people asked for manual configuration options in the beta, they were pretty much ignored, because the developer didn't see a need (Personally I don't see a need for pineapple on pizza, but some people seem to rave about it). Now we've got a new issue which has been going on for how many versions? Still we have no manual configuration options available to help trouble-shoot these edge cases, and fan-boy responses from moderators does nothing to help solve the issue, and only serves to annoy everyone. As stated, this is a commercial product, we've all paid for, and it hasn't worked a day since it's release. Off-line mode might be coming, but that post was over a month ago and was locked with no further info.

Edited by Anach

Share this post


Link to post
Share on other sites

Anyone have an update on this?  I just installed it on win10 machine, but it's showing problem connecting to the auto-config service.

Share this post


Link to post
Share on other sites
6 hours ago, wunderdojo said:

@Tommytong If all your machines happen to be Windows switch to Mouse Without Borders: https://www.microsoft.com/en-us/garage/profiles/mouse-without-borders/  It's free and works perfectly. If you have a mix of Windows and other operating systems Synergy is probably your best bet but you'll need to install v1.8. It works fine.

Back to 1.8 for me, again. I keep giving the new version a try but it's even more useless with each update, and really damaging the good name this software has had all these years. Mouse Without Borders would be great if only it supported Linux; at least it has manual configuration options.

At this point, I'm thinking they should probably just scrap v2.0, and refund everyone. It's certainly not added anything of value to the project in terms of features or usability, just the opposite in fact. Could have got more usability out of making a newer looking GUI for 1.8, with some better OS integration features. Or move onto 3.0, and try and learn from the mistakes of 2.0, with this cloud crap no one wants or needs, and maybe not use self-signed certs on commercial products.

Share this post


Link to post
Share on other sites

Only advantage I've seen so far, the few times I got it to run, is that the mouse retains focus when opening an app. it didn't before. Aside from that i see absolutely no advantage to using this update. It rarely runs. I'm really thinking that the upgrade to 2.0 was economic driven. Not too much of a revenue stream from a near perfect program like 1.8. This just bit them in the ass.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now