wunderdojo

Problem connecting to the auto-config service

146 posts in this topic

I thought I'd try Synergy v2 again today after last trying it in September. I never got it working in September, just errors. Sadly nothing has changed today, just the errors are different but it's still unusable for me. My computers work fine on v1.8 - Perfectly even.

But v2? I just get these auto-config service errors: ODamJaM.png

I saw an advertisement for Synergy 2 on LinusTechTips today and all I have to say is, are you guys for real? - Spending money on advertisements for what is a fundamentally broken product. I am honestly surprised at you guys, you should be really ashamed for charging for this rubbish. And I say that as a software developer myself that sells working software.

I hope you guys will go back to the drawing board by making the online authentication optional and allowing an advanced settings pane that gives us back all the granular control we had in v1.8 as clearly it would work fine if we could configure everything manually but relying on your servers to manage connections between our systems is just outside of your ability.

Also like another poster I am disappointed that you chose to use a self-signed certificate for the pubsub1.cloud.symless.com when a developer on this very forum told me the session IP lock for authenticating your client with your account was to increase security. I mean what a joke? your auto-config system could be MITM and have random systems attached to my synergy link where they have clipboard access?

Honestly I'm not even mad or angry I am just really disappointed I don't understand how you guys can be marketing this software that doesn't work and ruining the great reputation you once had, what happened to you guys?

Edited by JCY

Share this post


Link to post
Share on other sites

I just found that I can't even close Synergy v2 on my Mac because it creates three processes and if you close any of them the other ones just restart it. So I cannot drag the .app to trash because it's in use, I cannot close it from activity manager because it only lets you close one process at a time and there's nothing in my menubar to close it.

How the heck do I now close v2 and get back to v1.8? lol - I swear this is like the most lousy commercial software I've ever used.

Share this post


Link to post
Share on other sites

I actually had to setup a second user account on my Mac just to remove the application binary but I got it done. I would have edited my previous posts to combine all this into one message but the forum only lets you edit posts for a few minutes after posting.

You guys need to work on a proper uninstaller for Mac, clearly.

Share this post


Link to post
Share on other sites
2 hours ago, JCY said:

I just found that I can't even close Synergy v2 on my Mac because it creates three processes and if you close any of them the other ones just restart it. So I cannot drag the .app to trash because it's in use, I cannot close it from activity manager because it only lets you close one process at a time and there's nothing in my menubar to close it.

How the heck do I now close v2 and get back to v1.8? lol - I swear this is like the most lousy commercial software I've ever used.

My experience is also just terrible. I can't restart my mac due to three Synergy applications trying to run.
Having to make a hard restart because a software is blocking a soft one is just unacceptable.
Connecting my win10 Station and my MacBook (OS 10.11) is just not possible with v2.

Two months back, I uninstalled the beta4 because it was completely unable to connect for me and so many other testers. Now it is released and it's still utter trash. Always online is one of the most dreaded terms for a game and making it to a feature is just dumb. I can't use it for my home control system because it is and always will be a closed system (and because v2 doen't run).

"back to v1. 8" I guess... until the next update (a mail to all users would be nice, Symless should know now a lot of us are back to 1.8 and are waiting)

Share this post


Link to post
Share on other sites

I've requested a refund for the v2 I purchased in September. I gave them three months Sep-Dec. They went from Beta to Stable and it still is completely unusable for me. I've not been able to use the software to make a successful connection between my computers even one time with the v2 product.

Edited by JCY

Share this post


Link to post
Share on other sites

Same here. "There was a problem connecting to the auto-config service."

Is there any developer support for this problem?

Share this post


Link to post
Share on other sites

I'm using Synergy for past 7 to 10 years, dont even remember the exact time and a BIG fan. How it eased my life as developer who works on multiple machines and OS from Win to Linux to Mac. With release of Synergy 2 I was so excited but alas from day 1 I'm not able to use it (tried all 2.x versions). the same issue of "not able to connect auto-config server" has plagued me on all OS :(.

Nick, please please fix this issue. I really want to use Synergy 2

  • Like 1

Share this post


Link to post
Share on other sites

So here we all are, none of us can get the versions 2+ of Synergy to work. Yet we are no longer on beta, we are on "stable" versions. This is just utterly ridiculous! Synergy used to be a really good product from a great company. What on earth happened!?? Nick seems to have been there from the start, yet he is silent on these forums. We have a cloud service "feature" that no one wanted, no one likes, and mostly just doesn't work. Hopefully the retard who suggested this useless feature that doesn't work has been fired. Did any of the developers think to perhaps test the application on the various operating systems that it is supposed to support? It appears not, since no one in the real world has been able to get it to work. Self signed certs! Are you kidding me! The whole thing is such a joke. Nick Bolton, can you chip in here and let us know what the hell is going on? Why was the software released in a non working state? What was the idea behind creating a product so reliant on an internet connection when there was no need for it? What happened to the great product we used to love? Has the company appointed a new lead developer whose sole IT experience is setting up a personal Twitter account?

Share this post


Link to post
Share on other sites

yeah... I'm working on a refund now.  I'm happy with my VNC solution to my multi-host issues.

Share this post


Link to post
Share on other sites

maybe symless who sold the app should of known this, nick bolton please reply we are people that have paid to get you to 1.8 get your act together and give us an answer to this thread

 

Share this post


Link to post
Share on other sites

i do not think we will pay you more money for you to be a shill. give us what we paid for .. 

Share this post


Link to post
Share on other sites
On 12/17/2017 at 1:05 AM, JCY said:

I thought I'd try Synergy v2 again today after last trying it in September. I never got it working in September, just errors. Sadly nothing has changed today, just the errors are different but it's still unusable for me. My computers work fine on v1.8 - Perfectly even.

But v2? I just get these auto-config service errors: ODamJaM.png

I saw an advertisement for Synergy 2 on LinusTechTips today and all I have to say is, are you guys for real? - Spending money on advertisements for what is a fundamentally broken product. I am honestly surprised at you guys, you should be really ashamed for charging for this rubbish. And I say that as a software developer myself that sells working software.

I hope you guys will go back to the drawing board by making the online authentication optional and allowing an advanced settings pane that gives us back all the granular control we had in v1.8 as clearly it would work fine if we could configure everything manually but relying on your servers to manage connections between our systems is just outside of your ability.

Also like another poster I am disappointed that you chose to use a self-signed certificate for the pubsub1.cloud.symless.com when a developer on this very forum told me the session IP lock for authenticating your client with your account was to increase security. I mean what a joke? your auto-config system could be MITM and have random systems attached to my synergy link where they have clipboard access?

Honestly I'm not even mad or angry I am just really disappointed I don't understand how you guys can be marketing this software that doesn't work and ruining the great reputation you once had, what happened to you guys?

I just downloaded the latest version of Synergy, and can't do anything with it at all. Nothing but "There was a problem connecting to the auto-config service Retry."

That was a disappointment.

Share this post


Link to post
Share on other sites

Just adding another data point. Having an issue on OS X 10.11.6, MBP Retina 15" (mid-2016?).  I get the same problem connecting to the auto-config service error.

Tried everything, including reinstalling per below post.  Nada.

I have to say I feel like Symless is trying to make this product too simple, and locks out ability for "advanced users" (I don't consider myself advanced, but I like to get into the mix if I need it) to configure anything that may need tweaking.  Maybe I have the wrong impression, but it seems like this product is moving to the cloud in large part to get people to pay for the "cloud" service.

Sigh. I'm going to move back to 1.8 and check on v2 every once in a while--I'm not asking for a refund...yet.

Edit: The biggest PITA is that I have to uninstall v2 to go back to v1.8--on all the machines!

 

Edited by gctseng

Share this post


Link to post
Share on other sites

Just wanted to weigh in, I, like many others, tried 2 in the late betas and found it unusable, rolled back to 1.8. Today, I had a machine to replace, and since I was redoing Synergy on that machine, I decided to give 2 a try again. Of the three machines I loaded it onto, one had run 1.8 and 2.0, one had only ever run 1.8, and the third had never run any version of Synergy. The machine that had run 1.8 w/o issues and had tried the 2 beta, got "problem connecting auto-config". The machine that had run 1.8 only seemed to have no issues. The machine that was clean had "problem connecting auto-config", "problem connecting background service", and also closed the GUI several times. I'm not asking for a refund, 9$ isn't worth the time to ask for it, but it's terribly disappointing to hear that 2.X is still broken in a couple of major ways on a significant number of machines, that things like Wayland support are still planned for "someday", and that support is still no help. I think I'll go back to 1.8.X for a few more months, and I think I'll be looking into other solutions. All I need is network sharing of my mouse and keyboard, between Windows, Linux and MacOS. It shouldn't be this hard.

Share this post


Link to post
Share on other sites

If the product doesn’t work for you, just do what I did. Give up and move to a competing product. Others work, this does not, at least not for many of us. No product is worth this much hassle, especially when alternatives exist. 

Share this post


Link to post
Share on other sites
On 12/17/2017 at 10:05 AM, JCY said:

I thought I'd try Synergy v2 again today after last trying it in September. I never got it working in September, just errors. Sadly nothing has changed today, just the errors are different but it's still unusable for me. My computers work fine on v1.8 - Perfectly even.

But v2? I just get these auto-config service errors: ODamJaM.png

I saw an advertisement for Synergy 2 on LinusTechTips today and all I have to say is, are you guys for real? - Spending money on advertisements for what is a fundamentally broken product. I am honestly surprised at you guys, you should be really ashamed for charging for this rubbish. And I say that as a software developer myself that sells working software.

I hope you guys will go back to the drawing board by making the online authentication optional and allowing an advanced settings pane that gives us back all the granular control we had in v1.8 as clearly it would work fine if we could configure everything manually but relying on your servers to manage connections between our systems is just outside of your ability.

Also like another poster I am disappointed that you chose to use a self-signed certificate for the pubsub1.cloud.symless.com when a developer on this very forum told me the session IP lock for authenticating your client with your account was to increase security. I mean what a joke? your auto-config system could be MITM and have random systems attached to my synergy link where they have clipboard access?

Honestly I'm not even mad or angry I am just really disappointed I don't understand how you guys can be marketing this software that doesn't work and ruining the great reputation you once had, what happened to you guys?

I have the same problem as you here .
Ubuntu 17.10 and Windows 10     
version 2.0.4  Stables  ( that's #fakenews)
Så any other solution's then go 1.8 ?

Share this post


Link to post
Share on other sites

Bouth comps are green  but cant move mouse to the surface comp  

Screenshot from 2017-12-27 12-07-55.png

Share this post


Link to post
Share on other sites

Having issues aswell, and since it's related to the symless cloud I see no point in giving specific information about my setup. I don't understand why Synergy has a config file if it's not used to maintain connection between computers while the cloud is down - or even why the cloud has to be used at all.

[ Service ] [2017-12-27T18:10:06] error: can't send profile snapshot, not yet received from cloud
[ Config  ] [2017-12-27T18:10:07] debug: service cloud connection error
[ Config  ] [2017-12-27T18:10:07] debug: current version is update to date
[ Service ] [2017-12-27T18:10:07] debug: got user auth token: *****************
[ Service ] [2017-12-27T18:10:08] debug: retrying cloud connection
[ Service ] [2017-12-27T18:10:08] debug: closing existing websocket connection
[ Service ] [2017-12-27T18:10:09] error: websocket read error 335544539: short read
[ Service ] [2017-12-27T18:10:09] debug: clearing last profile snapshot
[ Service ] [2017-12-27T18:10:09] debug: retrying websocket connection in 26s
[ Service ] [2017-12-27T18:10:09] debug: retrying websocket connection now
[ Service ] [2017-12-27T18:10:09] debug: connecting websocket: pubsub1.cloud.symless.com:443
[ Config  ] [2017-12-27T18:10:09] debug: service cloud connection error
[ Service ] [2017-12-27T18:10:09] debug: retrying cloud connection
[ Service ] [2017-12-27T18:10:09] debug: retrying websocket connection now

 

Share this post


Link to post
Share on other sites

Wow.  I can't use synergy today because of issues connecting to the cloud.  What a joke.  Synergy needs to be able to work stand alone when the cloud is down.  This is very frustrating.  I agree with Revision and that why does this need to connect to the cloud in the first place.  

Share this post


Link to post
Share on other sites
2 hours ago, Xnaron said:

Wow.  I can't use synergy today because of issues connecting to the cloud.  What a joke.  Synergy needs to be able to work stand alone when the cloud is down.  This is very frustrating.  I agree with Revision and that why does this need to connect to the cloud in the first place.  

Same here. Installed 2.04 on both my machines last night, noticed moving between screens was a tad laggy. Bootup this morning and im getting "There was a problem connecting to the auto-config service" error on both machines. Uninstalled and rolled back to 2.02, issue still persists. Pretty inconvenient :/ 

Share this post


Link to post
Share on other sites

Yes. It is super annoying. It has been working on and off all day.  I hope they get this sorted asap.

Edited by Xnaron

Share this post


Link to post
Share on other sites

I am also getting "There was a problem connecting to the auto-config service. Retry"  Right now, v2 is completely unusable.

I have been pretty disappointed with v2.  I sent in a support ticket asking about changing the modifier keys and was told "We'll be adding this in Synergy 2.1 which is due early 2018. Are you happy to wait?"   I'm not sure why I'm supposed to be happy to wait.

Considering a refund...

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now