wunderdojo

Problem connecting to the auto-config service

146 posts in this topic

7 hours ago, Angelos Ching said:

The world does not revolve around Symless and their servers.
There are many computers in this world running in isolated networks as well.
They could have used Avahi/Bonjour for automatic service discovery and configuration.
But they ended up with a fragile "cloud"(?) based architecture. 

My post wasn't in regards to Symless, but other alternative products. You should try to read the thread, to gain context before posting. 

Edited by Brian Davis

Share this post


Link to post
Share on other sites

Bonjour might have worked for Mac and/or Windows.  I looked into Avahi. For Linux, not so much.  The web page for that project was dead, it had not been updated in years (millennia in internet time), and I could never get it to work.  It looked to be abandonware.

That was probably behind the decision to do this some other way.

Share this post


Link to post
Share on other sites
11 minutes ago, Mike Van Pelt said:

The web page for that project was dead, it had not been updated in years (millennia in internet time), and I could never get it to work.  It looked to be abandonware.

Really? The latest news entry in http://avahi.org/ is a release announcement from July 2017.

Share this post


Link to post
Share on other sites
2 hours ago, eth0 said:

Really? The latest news entry in http://avahi.org/ is a release announcement from July 2017.

Really?  (checks)  Interesting.  That didn't exist back when I looked into it a couple of years ago.  At least, google didn't find it.

Avahi didn't work.  I was getting log messages complaining that Synergy was using the Apple Bonjour compatibility layer of Avahi, that's not well supported, and I should fix "my" application to use the native API of Avahi.  For more information see <http://0pointer.de/avahi-compat?s=libdns_sd&e=synergys>, which gets a 404.  My googling of "avahi" didn't find me anything helpful.  Some other pages, I think I recall, which had not been updated in ages. 

 

 
Edited by Mike Van Pelt

Share this post


Link to post
Share on other sites

I think I recall when I tried going to avahi.org, it redirected me to that 0pointer.de site, which had nothing about Avahi.

Share this post


Link to post
Share on other sites
On 12/17/2017 at 9:05 AM, JCY said:

Also like another poster I am disappointed that you chose to use a self-signed certificate for the pubsub1.cloud.symless.com when a developer on this very forum told me the session IP lock for authenticating your client with your account was to increase security. I mean what a joke? your auto-config system could be MITM and have random systems attached to my synergy link where they have clipboard access?

@JCYI have posted about the self-signed certificate here

With respect to clipboard access, I wish to make it clear that the connections to our cloud do *not* carry any keyboard, mouse or clipboard data between your machines.

To be frank, in our current security model, there is wiggle room for some classes of attack to be successful, but addressing these without compromising ease-of-use is non-trivial.

Right now we're keeping user data safe in most scenarios (like using Synergy berween machines on insecure WiFi, or on untrusted internet connections) and are primarily focused on improving reliability and useability. Future versions will defend against most attacks.

Share this post


Link to post
Share on other sites
4 minutes ago, Andrew Nelless said:

Right now we're keeping user data safe in most scenarios (like using Synergy berween machines on insecure WiFi, or on untrusted internet connections) and are primarily focused on improving reliability and useability. Future versions will defend against most attacks.

When will useability/auto-connect service be fixed?  I still can't use Synergy 2.0.4 between machines...

Share this post


Link to post
Share on other sites
1 minute ago, Scott- said:

When will useability/auto-connect service be fixed?  I still can't use Synergy 2.0.4 between machines...

@Scott-

Our auto-config server is currently operating normally. I couldn't find any logs on the forum. Are you able to submit a tech support request at https://symless.com/contact/customer-support ?

Share this post


Link to post
Share on other sites
28 minutes ago, Andrew Nelless said:

@Scott-

Our auto-config server is currently operating normally. I couldn't find any logs on the forum. Are you able to submit a tech support request at https://symless.com/contact/customer-support ?

 
I tried to send a request but pressing the submit button does nothing (on macOS and win10/ Safari,Chrome and Edge).

Share this post


Link to post
Share on other sites
17 minutes ago, Scott- said:

I already have an open ticket and have submitted logs.

I had a quick look, and I think I've identified a problem with reconnect logic here that could be causing issues. I'll look in to it and see if this can be added to v2.0.5

Share this post


Link to post
Share on other sites
27 minutes ago, Andrew Nelless said:

I had a quick look, and I think I've identified a problem with reconnect logic here that could be causing issues. I'll look in to it and see if this can be added to v2.0.5

So the software will be useless until a patch is released?

Share this post


Link to post
Share on other sites
7 hours ago, Andrew Nelless said:

 

With respect to clipboard access, I wish to make it clear that the connections to our cloud do *not* carry any keyboard, mouse or clipboard data between your machines.

Thank you for clarifying, my concern here wasn't that my clipboard would be going to your servers. My concern was your cloud system would enable an attacker to get their own system added to my Synergy configuration of systems and then they could directly exfiltrate my Clipboard.

I am assuming based on your post that you linked that you're doing manual certificate verification within Synergy itself so this is a non issue. I do find it concerning though that you guys upgraded the server and forgot to reissue your own certificate. I mean that literally broke the entire application for all of us.

Why not make the cloud thing optional? Just give me a box to enter in my machine IP Addresses manually and then make it popup confirmation boxes on each machine that I manually specify to allow connections.

Honestly I don't understand why this software needs a remote server outside of my network to orchestrate anything it feels really lazy when you could use multicasting combined with a 6 digit passcode confirmation. Ya know like how everyone does these kinds of pairing things (Bluetooth, 2Factor, iPhone to iTunes remote and more).

Edited by JCY

Share this post


Link to post
Share on other sites

I was seeing this for a while this morning (US-West, 8-10AM) then it resolved.  Frustrating, and I'm a paying customer.  Why not a local Redis cache or something?

Share this post


Link to post
Share on other sites

After the replace of 3rd party signed ssl certificate, I can run the v2 without the problem connecting to the auto-config service!

But the function is simple and incomplete. Hope the birth of powerful v2.

Share this post


Link to post
Share on other sites

I am from China, and I think the core of my problem is the cloud server blocked China region to connect before, and it allows to connect now. Not the replace of 3rd party signed ssl certificate.

Share this post


Link to post
Share on other sites

aaaaaand - it's offline again.  Doing the restart directions for a Linux machine (has a lot of VMs so don't want to reboot the physical host if I can avoid it), the "systemctl restart synergy" as directed, which made the Synergy window now start saying it can't connect to the auto-config service, and retrying is useless.

Synergy 2.04-stable is not stable.  I've tried using it for the day, it's broken more often than it works, and that's a pity, because it's glorious when it does work.

Share this post


Link to post
Share on other sites

had problems with connecting to the auto config service, with websocket errors & 404s in the logs.  

1)  The support form is terrible.  There are tons of errors in the console log,  and the webpage just sits there with no indication that something is not right.

2)  Add a logout function/button to the Synergy-Config program (right-click with a contextual menu item 'log this computer out').  I could not get any of the logs from computer2 that i uploaded to appear in support form drop-down.  Synergy thought it was logged in but it whatever Identifier Key/ID that it was using was not correct (or even there?). I looked in all the files i could find in the normal directory & the AppData directory, finally combed the windows registry and found where the ID was stored, deleted it.  Ran the synergy-config again, and finally got it to ask me to login from the website, and it started working again.

Share this post


Link to post
Share on other sites

Why are synergyc and synergys gone? I reverted to the 2.0.0 beta and everything is back to working great that way.  Got a script that runs and everything.  It's all on my network, no need to go anywhere else.  Why would I want a cloud service for a bunch of machines sitting on the same LAN anyhow???

Share this post


Link to post
Share on other sites

Does anyone have a solution for MacOS when this error appears? Reinstalling Synergy does not resolve this for me. It's worth mentioning that in the logs I'm getting a handshake failure and a 400 error when attempting to connect to the cloud.

Also, CLOUD??? WTF? Give us at least some way of configuring it to access config files from a local server rather than forcing us onto an always online system.

Share this post


Link to post
Share on other sites

Yeah, I was pretty let down when I discovered the new "stable" version did not include synergys or synergyc.  I have machines that don't connect to the internet.  I'm not about to use some fancy routing and firewall rules nor would I want to to connect to some cloud service.  Especially considering mouse and keyboard input are involved.  That's not really something I want floating around on the internet.  Synergy was getting so amazing and then this happened.  Sorry Symless, I love the previous version of your software.  Like top 3 applications I've been using for a decade.  But this is not too good.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now