HelloThere

Mouse Cursor appearing at the middle of the screen?

20 posts in this topic

Hello there,

Setup configuration:
Windows 10 (1709) Server
MacOS High Sierra (10.13.1) Client

Its not really a big of a problem but it is somewhat very annoying that every time i moved the cursor from the server (windows) to client (macOS), there is a brief moment where a second cursor will appear at the middle of the server's screen. Although it disappears quickly with in a second or two, it is still very annoying as there are times when this confuses me as to where my mouse cursor really is... This is not the case when going from client (macOS) to server (windows) where the action is really smooth... 

How can i stop this from happening? I already tried reinstalling the program and it didn't work.

Cheers

PS. As of the moment i am not very keen to start using synergy 2.0 as I've read in the forum that there are still a-lot of bugs that needs to be fix.. plus it seem that  some of the features  are not yet supported.. 

  • Like 1

Share this post


Link to post
Share on other sites

Same here! Except the cursor stays in the middle of the screen when I mouse away from the client. I have two Windows 10 computers.

Share this post


Link to post
Share on other sites

Me too!

I have two PC's with Windows 7 Ultimate and Windows 10 and Synergy 2.0.2 stable: the cursor appears on the other screen (exactly on the center of the screen) while I move to the other.

No a big issue but is very Very annoying!!!!

Symless, you have made a fabulous sw, please, make it perfect and correct this !!!! :-)

Edited by symace

Share this post


Link to post
Share on other sites

I'm having this same issue. Win10 desktop and macOS laptop. Cursor jumps to middle of Windows machine when moving to macOS machine.

Share this post


Link to post
Share on other sites

Same issue with my two windows 10 PCs. Very annoying any time I want to watch something 

Share this post


Link to post
Share on other sites

I'm experiencing this too.

I have a Windows 10 machine and (to the right of it) a macOS machine. Windows 10 is my main machine, and I don't experience any issues when working on it. When I move my cursor to the right, over to my macOS display, I'm often met with some resistance. Eventually, after a few seconds, I can get my cursor to macOS. But, after a few seconds on the macOS screen the cursor will vanish and re-appear at the center of my Windows 10 machine.

If I reach over and move the macOS cursor around with the track-pad, it does something similar. After a few seconds of moving the cursor around, the cursor vanishes. If I stop moving it around, and remove my finger from the trackpad, the cursor will re-appear at the center of the macOS screen.

What's going on?

Share this post


Link to post
Share on other sites

I see similar issues as well.  As Nick suggested, I posted a support ticket describing details of mouse "jump to the middle" behavior as I see it happening still with 2.0.5.  I also seeing requests to "click to RETRY" to connect to the background service a lot - which is painful to do when you can't use the synergy keyboard/mouse to reach the RETRY to click.  I asked if the developers would implement some sort of automatic retry (which backs off time wise when it continues to fail)... I find that 1-2 clicks usually fixes things, so I wish it would retry!

If the mouse would quit jumping to the center of Mac screens (for me), and transient drops of communication with the backend would self-heal, I would be much happier.

However, as is - I'm a HUGE FAN, because makes my life much much much easier as it is already.  I hope our feedback can help even more!

Edited by oregonwolverine
typo fix
  • Like 1

Share this post


Link to post
Share on other sites
9 hours ago, oregonwolverine said:

I also seeing requests to "click to RETRY" to connect to the background service a lot - which is painful to do when you can't use the synergy keyboard/mouse to reach the RETRY to click.  I asked if the developers would implement some sort of automatic retry (which backs off time wise when it continues to fail)... I find that 1-2 clicks usually fixes things, so I wish it would retry!

Auto retry wouldn’t help here as the config app not talking to the background service is not the issue; clicking on the client causes it to share it’s keyboard and mouse, which effectively restarts the core process and resolves the issue.

The bug that we’re urgently working on to fix this is related to stability of the background service. Thanks for your patience and thanks for opening a support ticket; this’ll provide valuable data to our dev team which will help us fix the problem faster! 😊

Share this post


Link to post
Share on other sites

Clever, and interesting.  Good luck!  I will watch for updates!

Share this post


Link to post
Share on other sites

I should note that I did not have any of these problems before the latest update.

Share this post


Link to post
Share on other sites

Has there been a fix for this yet?  I'm experiancing it and running 2.0.10.

Share this post


Link to post
Share on other sites

2.0.10 does not fix yet; I have been assured this is a known problem but the fix will take a month or two still

Share this post


Link to post
Share on other sites

Bump. Has there been a fix posted? Running Windows 10 on 2 machines, same monitor size, mouse cursor appears momentarily at the center of the monitor each time I swtich between machines. 

Thanks

Share this post


Link to post
Share on other sites
Posted (edited)

I've been waiting so long for a fix to this. This bug is the single biggest annoyance of my day, every day. 

My wife and I share a media computer and we're both constantly accessing it. We each have a computer, one mac, one windows 10, both set up with synergy as servers, and one media center computer (windows) set up as a client that connects to both servers.

When she moves her mouse into the media center computer and then moves it out, the media center's mouse cursor gets stuck on top of all applications (the video we're playing in VLC, Chrome, etc) in the center of the media center screen.

To get rid of the cursor, she has to ask me to move my cursor into and out of the media center computer. This happens about 100 times every night, and it's driving me a little crazy (a lot actually). It's been happening for years. I've been a Synergy user since the beginning, and have evangelized for it endlessly - and I never thought I'd come to see the day when I loathed it. 

Edited by neimad

Share this post


Link to post
Share on other sites

Nevermind, I fixed it myself. I'm running the client for my wife's computer inside a child process, capturing the stdout from synergyc and when her mouse enters the screen, I focus the window that synergy is running in (which sits off-screen so it's hidden). That's what it took to workaround this bug - simply having the window focused that synergyc.exe is running in will make the mouse cursor disappear when her mouse leaves the media computer. I noticed that, and then figured if I could capture the mouse entering and leaving, and auto-focus that window (using nircmd), it should work, and it did work. Not the easiest workaround but finally after all this time, all it took was one night of hacking.

Share this post


Link to post
Share on other sites

I'm experiencing this regularly using 1.10.1 which appears to be the latest.  Server is Win 8.1, clients Win10 and MacMojave and Ubuntu though the linux machine is off currently.  I CONSTANTLY get stuck with an invisible cursor that I can only see by hitting the control key to locate the mouse.  Nothing I do with mouse will move it off this location.   The only way I get out of this is cnt alt delete, choose task mgr and it immediately unlocks and is back to normal.   It just happened after that last sentence :-(

Is this fixed somewhere ? seems it was been identifed a long time ago.

Share this post


Link to post
Share on other sites

I turned off Synergy for the last week.  It is wonderful to not have to deal with the cursor getting stuck.   Utter joy.  Why don't you folks fix this crap.  Synergy, back in the day was a wonderful product, those  days are long gone.  Just for kicks I turned it on to do something on one of my macs.  Less than 2 minutes and the freakin' mouse is stuck dead center on server machine.   This is crazy.

 

Share this post


Link to post
Share on other sites

I decided today I had to try to figure out what is killing me here and I ended up finding one of my machines running older 1.9 series vs others running 1.10.1.   The 1.10.1s were also telling me there was a 1.10.2.   I updated everything to 1.10.2.   At the moment, about 2 hours in, everything is working well.  I have not used Synergy without the stuck cursor for anything near this long anytime in the recent past so I'm quite hopeful that me messing up some versions or updating some but not all was contributing to my problems.  Fingers crossed the fix was this easy.

Share this post


Link to post
Share on other sites

Seems better but still gets stuck regularly in the middle of the server machine.  All running latest 1.10.2.   I'm just shutting it off and only using it when desperate :-(

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now