JohnCLeBlanc

Does Synergy prevent monitor from going to sleep?

59 posts in this topic

On 16/03/2018 at 3:58 PM, Dash Minus said:

Checking back in. Any Linux users having the same problem as me, and if so, any workarounds?

I have the same issue (Ubuntu 17.10 gnome Xorg, server on Mac) and the screens do not sleep. They have sometimes, so I need to know what's happening. I would also be interested in an explanation and a workaround.

Share this post


Link to post
Share on other sites

I'm using Synergy 2.0.7 on two Macs (MBP and iMac) and they both experience this issue. When the MBP does go to sleep, it often freezes on a back screen until forcing a restart.

Share this post


Link to post
Share on other sites

I have the same problem with Synergy 2.0.8 stable with Ubuntu 16 and WIndows 10, none of the monitors go to sleep. :(

Share this post


Link to post
Share on other sites

version 2.0.9 is now available. It couldn't hurt to try the current version to see if your issue persists

Share this post


Link to post
Share on other sites

The "powercfg -requests" command gives me the result "synergyc.exe" is preventing from sleeping. Then should I replace the "synergy-core.exe" part to the "synergyc.exe"? Thanks for reading.

Edited by hiphopbros

Share this post


Link to post
Share on other sites
On 11/20/2017 at 2:49 PM, Theo said:

Had exactly the same problem on all clients, so I did

powercfg /REQUESTSOVERRIDE process synergy-core.exe display system

from elevated command prompt on every client machine and it took care of it.

Thanks for the nice tip. My windows 10 gives me "synergyc.exe" is the issue when I did "powercfg -requests". Should I replace the "synergy-core.exe" part in you code to the "synergyc.exe"? After that, How do I cancel or remove the overriden power setting from your code in my machine? Thanks man.

Edited by hiphopbros

Share this post


Link to post
Share on other sites
1 hour ago, hiphopbros said:

Thanks for the nice tip. My windows 10 gives me "synergyc.exe" is the issue when I did "powercfg -requests". Should I replace the "synergy-core.exe" part in you code to the "synergyc.exe"? After that, How do I cancel or remove the overriden power setting from your code in my machine? Thanks man.

You are probably using Synergy 1, so the name is different. Yes, just replace the name, and if you ever want to remove the override, type the command without specifying the types (display, system etc) at the end: "powercfg /REQUESTSOVERRIDE process synergyc.exe"

Share this post


Link to post
Share on other sites
On 2018-04-10 at 8:52 AM, GranPaSmurf said:

version 2.0.9 is now available. It couldn't hurt to try the current version to see if your issue persists

Yeah, I've updated on my linux (ubuntu 16) and windows 10 machine and the problem is still there.

weird thing is: I see the screen becoming blank, but turns back on to show the lockscreen

Edited by ichigeki

Share this post


Link to post
Share on other sites
On 11/20/2017 at 6:49 AM, Theo said:

Had exactly the same problem on all clients, so I did

powercfg /REQUESTSOVERRIDE process synergy-core.exe display system

from elevated command prompt on every client machine and it took care of it.

Much appreciated! I wish this was done by default, or at least have it as an option during installation.

Share this post


Link to post
Share on other sites

I'm now on Ubuntu 18 with Synergy 2.0.12-beta.  As soon as I turn on any of the 4 machines connected to my account, the screen will never go in sleep mode on any of the 5 machines.  Anyone else has this problem with Ubuntu?  I know there is a workaround for Windows, but most of my machines are using linux.

Share this post


Link to post
Share on other sites

I'm using synergy1pro. powercfg works on windows, but it makes another issue. Widnows thinks it is idle time whilie my mouse point is only on another computer. When the fan goes on for the idle time, my mouse point should go to the loud fanning computer to stop it. I rather make the computer sleep manually.

Share this post


Link to post
Share on other sites
2 hours ago, ichigeki said:

I'm now on Ubuntu 18 with Synergy 2.0.12-beta.  As soon as I turn on any of the 4 machines connected to my account, the screen will never go in sleep mode on any of the 5 machines.  Anyone else has this problem with Ubuntu?  I know there is a workaround for Windows, but most of my machines are using linux.

have you tried synergy1?

Share this post


Link to post
Share on other sites
6 hours ago, hiphopbros said:

have you tried synergy1?

Actually, I haven't, i'll give it a try! 

 

Share this post


Link to post
Share on other sites

Ok, I uninstalled Synergy 2 on all my machines and replaced with Synergy 1, sleep mode working as espected, problem solved ! 

 

  • Like 1

Share this post


Link to post
Share on other sites
8 hours ago, ichigeki said:

Ok, I uninstalled Synergy 2 on all my machines and replaced with Synergy 1, sleep mode working as espected, problem solved ! 

 

It must be painful to manage 4 machines. I think the developers are thinking automatic stuff is good. I hope they are making programs with more options and manual stuff not automatic hidden features.

Share this post


Link to post
Share on other sites
On 6/8/2018 at 8:21 AM, hiphopbros said:

I hope they are making programs with more options and manual stuff not automatic hidden features.

The new approach for Synergy 2 is to give users a hybrid of automatic and manual. Automatic to save time, and manual for when that goes wrong.

Share this post


Link to post
Share on other sites

I just stumbled on this thread while searching for a fix to this issue for the latest of Synergy 1. I found that the command mentioned above needs to be changed. 

powercfg /REQUESTSOVERRIDE process synergy-core.exe display system
powercfg /REQUESTSOVERRIDE process synergyc.exe display system

I also ran the one below as I had two synergy processes running (c and d). I'm sure that "c" stands for client and "d" for daemon, but @Nick Bolton would have to verify.

powercfg /REQUESTSOVERRIDE process synergyd.exe display system

 

Share this post


Link to post
Share on other sites

It's synergyc.exe for Synergy 1 and synergy-core.exe for Synergy 2. The original question was about the latter.

Share this post


Link to post
Share on other sites
On 6/15/2018 at 9:48 AM, MattTheProgrammer said:

I just stumbled on this thread while searching for a fix to this issue for the latest of Synergy 1. I found that the command mentioned above needs to be changed. 

powercfg /REQUESTSOVERRIDE process synergy-core.exe display system
powercfg /REQUESTSOVERRIDE process synergyc.exe display system

I also ran the one below as I had two synergy processes running (c and d). I'm sure that "c" stands for client and "d" for daemon, but @Nick Bolton would have to verify.

powercfg /REQUESTSOVERRIDE process synergyd.exe display system

 

powercfg /REQUESTSOVERRIDE process synergyc.exe display system

still does not override the request. Do i need a reboot?

Share this post


Link to post
Share on other sites

I'd also like to fix this on Windows 10 running Synergy 1. 

Recently installed it on my laptop at work so I can flick between it and my desktop but it keeps my laptop awake, which I don't want. I'm happy for it to sleep after inactivity.

The powercfg /REQUESTSOVERRIDE process synergyc.exe display system 

does not work... i've also rebooted and powercfg /requests shows the same thing still.

Help? 

Share this post


Link to post
Share on other sites

I'm seeing this between a Win10 machine and an Ubuntu 18 system with KDE.   Both machines have two HP monitors and their own keyboard+mouse.   Both are set up with a 10 minute power-save on the monitors only.

I'm running Synergy 2.0.12-beta.

Sometimes either one computer or the other will turn off the monitors it owns - but sometimes neither turn off - and I've never seen all of the monitors being off at the same time.

Ubuntu 18 no longer ships with screen savers (they are obsolete in an age where we have LED monitors that don't "burn in") - so the power-save option is now the only reasonable way to get a blank screen...and power-save is a better mechanism anyway because it actually shuts off the raster and lets the monitor itself know to go into a low power mode.

As others have mentioned - solutions that put the CPU to sleep are simply not viable for people who still want long-running calculations to proceed when the monitors are shut off.  But having four bright glowing monitors in my guest bedroom/office 24/7 is also not viable.

The latest synergy that allows either computer to be controlled by either mouse/keyboard is otherwise fantastic - and it would be a shame to have to dump it just because of this problem.

 

Share this post


Link to post
Share on other sites
On 10/14/2018 at 5:29 AM, Steve Baker said:

(they are obsolete in an age where we have LED monitors that don't "burn in")

The issue isn't burn in; it's power usage. 

Share this post


Link to post
Share on other sites

Yeah I am running two clients Windows 10 r1809 and power saving isnt working any more :(

I've tried "powercfg /REQUESTSOVERRIDE process synergy-core.exe" in an elevated privledged CMD session and its main no difference.

What am I doing wrong?  Any help would be really appreciated.

Share this post


Link to post
Share on other sites
On 10/30/2018 at 5:56 AM, mikeblas said:

The issue isn't burn in; it's power usage. 

Right - which is why Ubuntu has a power save mode - and NOT screen savers (which no longer save the screen - but DO consume power).

Anyway - doesn't matter - that's what it has - and Synergy screws it up.

For me, it's not just about power usage - it's also about wanting the room to go dark when I'm not using the computers.

 

Share this post


Link to post
Share on other sites
8 hours ago, HouliNZ said:

Yeah I am running two clients Windows 10 r1809 and power saving isnt working any more :(

I've tried "powercfg /REQUESTSOVERRIDE process synergy-core.exe" in an elevated privledged CMD session and its main no difference.

What am I doing wrong?  Any help would be really appreciated.

I don't think you are doing anything wrong - it seems to be a bug in Synergy.

FWIW - what I find is that with two computers - each with two screens - one of the two computers will power down - but in so doing, somehow triggers synergy to produce some kind of a mouse or keyboard event...which wakes up the other computer - when that one eventually goes to sleep - synergy wakes up the first one again - so screens turn on and off all the time and there never seems to be a time when both computers can finally get to sleep.

 

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now