Mike Van Pelt

Delay in cursor move around Windows login

30 posts in this topic

Thanks for the thoughts everyone. 

I've been trying to stick with Synergy 1 as Synergy 2 has been perpetually in beta. Maybe it would be fine. But, it generally works pretty well except for this one annoyance. I was hoping the detailed writeup my help someone fix it. Maybe some day!

Share this post


Link to post
Share on other sites

I am having the same issue. Both server and client are Win10 1903.

Share this post


Link to post
Share on other sites

Hi all

Just spent some time reading through all the posts. 

@Mike Van Pelt has it right. when windows locks, applications that want to run or interact on that screen require administrative privileges. Synergy tries to follow the rule of running with the least permissions required and while a user is logged in admin rights are not needed. However when the user locks the computer the program cannot just elevate itself. Something to do with Microsoft's handles. So instead the program restarts with the required permissions and the reconnection with clients takes a bit of time to happen. 

What you can try is setting synergy to require elevation Always  in the settings and see if that helps with the issue. It just means synergy will always run as administrator from then on.

Jamie

Share this post


Link to post
Share on other sites
Posted (edited)

I don't know how I could have missed that setting, but the moment I turned it to "Always", I have yet to have it kick me off after requesting admin rights. THANK YOU for pointing this out to me, as I was just frustrated enough to give up on it.

 

Side note: This post was started on Feb 8th 2019, and it is now July 1st . . . Synergy support needs to pay more attention to its forums! This could have been resolved within the first few days if someone had just pointed this out in the beginning. PLEASE ADD THIS INFORMATION TO YOUR FAQ!!!!!!!!!!

Edited by MRiechma

Share this post


Link to post
Share on other sites

Works for me too! Thanks so much for the workaround! Changing the "Elevate" setting to "Always" fixes this completely. 

Rob

 

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now