Jump to content
Get Synergy | Open a support ticket
Symless Forums

Microsoft Remote Desktop on Mac, No Shift Keys


Recommended Posts

Hello,

This is an issue on version 1 also, but I figured I'd post it here.  I have two Mac's that I share a keyboard / mouse between.  If I go to the second Mac which I am using Synergy to control the keyboard and Mouse, and I try to run Microsoft Remote Desktop to access a Windows box over an RDP session, the shift keys do not work.  If I use the keyboard from that machine it is fine.  The Shift keys just do not work within Microsoft Remote Desktop RDP session when you try to use them through Synergy.  This happens with the old version of Synergy and older versions of Microsoft Remote Desktop.  As a result, if I use Microsoft Remote Desktop, I need to use an actual keyboard if I expect to use the Shift Keys.  They shift key works fine within the admin screens of Microsoft Remote Desktop, just not inside of the RDP session.  VNC, OSX Screen Share, everything else is fine but RDP within Microsoft Remote Desktop.  Anyone have an ideas?

This issue occurs on Mojave and High Sierra, 

Osxster

 

Edited by Osxster
Link to post
Share on other sites
  • 11 months later...

I am a brand new Synergy user (had it installed and running for about a week) and I've just enchanted this EXACT SAME PROBLEM. Same circumstances, same situation. I have two Macs and I'm sharing a bluetooth keyboard and mouse between them. On the second Mac, (the "client" Mac), I run Microsoft RDP for Mac to connect to a Windows machine. In the session, the Shift keys aren't being recognized--in fact, I think it's all modifiers, including Control and Option. The problem happens regardless of whether I'm using v8 or v10 of the RDP software. The problem does NOT happen if I run the RDP session on the first mac (the "server" Mac). The problem also does not happen if I use the keyboard that is physically attached to the second Mac.

 

The OP posted about this problem on May 14, 2019, and today as I write this is is May 13, 2020, so this problem has been known about for a year. Is any progress being made on a fix?

-jlanter

Link to post
Share on other sites
  • 4 weeks later...
  • 2 months later...

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
×
×
  • Create New...