Martin Fürholz

Bug: Synergy 1 does not remember the server IP on macOS Mojave when I reboot instead of shutting down and restarting.

2 posts in this topic

Due to issues after an upgrade to Windows 10 1903 I went back to Synergy 1.

But it doesn't remember the hostname/server IP on my Macbook when I reboot after the installation, instead of shutting down and starting up.

I did a fresh install with the instructions https://members.symless.com/help/s1-troubleshooting/s1-reinstall multiple times.
The only time I got it to work was when I switched to server-config and then back to client, for some reason it remembered the client settings afterwards. But oddly then it keeps asking for the server config file after every boot, even if it's set back to client mode.

 

So now every time I reboot the Macbook, I get a prompt from Synergy, telling me that I have to fill in the host name.

I uninstalled, rebooted and reinstalled multiple times with the instructions linked above, also - FWIW - with the version of those instructions for Synergy 2.

Other steps I tried:

• Toggle the setting in system preferences / Security

• Toggle the autostart setting in system preferences.

• Tried using the host machine name instead of the host IP, but it then tried to use the IPv6 address and failed to connect.

 

The only way to get rid of the problem was to shutdown completely and then start the MBP normally.

Share this post


Link to post
Share on other sites

Can you send a screenshot of the Synergy 1 interface on all machine(s) involved in the setup? I'd ask for logs, but I really doubt they'd help with your particular scenario.

If I may ask though, why are you using a static config for your server? Does autoconfiguration not work in your environment for some reason? I do know that that's the recommended use for Synergy if you can because it'll use Bonjour to auto-discover the server service on the network. But I know there are cases where Bonjour packets are blocked by certain intranet firewalls within corporate organizations, as an example, so I'd just like to confirm why your network won't support autoconfig.

 

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now