Jump to content
Get Synergy | Open a support ticket
Symless Forums
Nick Bolton

Issue: OpenSSL function error on Linux

Recommended Posts

Nick Bolton

We are aware of an issue in Synergy 1.10.3 where an invalid OpenSSL function is called. This occurs on older versions of Linux, or versions of Linux with an older version of OpenSSL.

openssl error: error:140C5042:SSL routines:ssl_undefined_function:called a function you should not call

Please open a support ticket if you're experiencing this issue.

Note: This thread is a continuation of an earlier locked thread.

 

Share this post


Link to post
Share on other sites
Ne+Face
On 9/13/2019 at 11:22 AM, Nick Bolton said:

Hi there, there is an issue on some Linux distros where Synergy uses an incorrect version of OpenSSL. We will be working on fixing this issue in a future version. For now, please use version 1.10.2 if you're experiencing this issue.

Where do I find this distribution? I have debian 10.

Share this post


Link to post
Share on other sites
Nick Bolton
13 hours ago, Ne+Face said:

I have debian 10.

You may need to use v1.10.2, please go ahead and open a support ticket so we can help you with that.

Share this post


Link to post
Share on other sites
ywu

Not sure what the consideration is but isn't it easier to open the old versions downloading for fallback? I reported the same issue happened on my Ubuntu 16.04 + OpenSSL 1.1.1d but just don't want to report another (series of) support ticket(s) to get/try the alternative (start from 1.10.2).

Share this post


Link to post
Share on other sites
Nick Bolton
18 hours ago, ywu said:

open the old versions downloading

Yes, we do plan to add the last few versions to the website as that'll make it easier. In the meantime, please open a support ticket. Thanks.

Share this post


Link to post
Share on other sites
Jamie Newbon

Hi Guys,

Initial testing on this build looks to have solved the issue, would those affected by the TLS/SSL `undefined function` bug mind giving this version a try, and reacting to this post if it works, or posting and details below if it didn't.

https://snapshots.symless.com/public/6556-tls/

Thanks 

Jamie

Edit: updated link due to password protection, the link is public access now.

Share this post


Link to post
Share on other sites
Vrzi
On 5. 11. 2019 at 10:13 AM, Jamie Newbon said:

Hi Guys,

Initial testing on this build looks to have solved the issue, would those affected by the TLS/SSL `undefined function` bug mind giving this version a try, and reacting to this post if it works, or posting and details below if it didn't.

https://snapshots.symless.com/public/6556-tls/

Thanks 

Jamie

Edit: updated link due to password protection, the link is public access now.

This dev version works as client with ssl on Lubuntu 16.04. 

Share this post


Link to post
Share on other sites
nleco

I just tested this out briefly with my Macbook Pro (late 2013) running Mojave 10.14.6.

It works and connects to a client using Ubuntu 16.04 LTS.

I am able to go between screens and click around.

Edited by nleco

Share this post


Link to post
Share on other sites
zd-dalibor

I have this problem also on fedora workstation 31

openssl error: error:140C5042:SSL routines:ssl_undefined_function:called a function you should not call

I am using this file to install the application "synergy-1.10.3-120.stable.ca35737a_centos_el7.x86_64.rpm".

Share this post


Link to post
Share on other sites
zd-dalibor

By the way, my SSL version is: 

$ openssl version
OpenSSL 1.1.1d FIPS  10 Sep 2019

 

Share this post


Link to post
Share on other sites
Jamie Newbon

Hi guys

Synergy v1.11.0-rc2 is available for testing which includes the TLS fix as well.

Here are the changes in this version.

Features:

  • #6518 Key combination that will force a server restart

Enhancements:

  • #6588 Version number header with update check
  • #4957 Server fails to start up due to synwinhk.dll is in use

Bug fixes:

  • #5294 Cursor lockout at Windows server login screen
  • #6569 Unable to run on macOS 10.15 Catalina
  • #6561 Debian buster no longer supports CA key length of 1024
  • #6556 Function missing error from OpenSSL/TLS
  • #6575 Service start error on Windows
  • #6566 Debug message output mistakenly as info message
  • #5959 User interface failed to load local fingerprint

If you find a bug with this version, please submit an issue on GitHub, or contact support.

Thanks,
Jamie

  • Like 1

Share this post


Link to post
Share on other sites
VinnyH

Thanks!  This fixed my SSL issues.  No more SSH tunnels! 

 

--Vinny

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...