Travis Hoff

Error: "Server refused Client with our client name"

3 posts in this topic

Hi Synergy Team. I hope you are all well. I tried to submit a trouble ticket, but kept getting Error code: SSL_ERROR_RX_RECORD_TOO_LONG when going to

Your support ticket form will not let me submit without a URL being generated from
I made sure any and all Ad Blockers were disabled and still no success.
Here is my Ticket though:
I'm in need of help. I've been a proud user of synergy for quite some time now and love it! However, recently I had to do a factory reset on my laptop, and since then, I cannot get Synergy to connect. The server and client computers are set the same as they were previous to reset. I've tried every avenue of troubleshoot I personally can think of, which admittedly is very limited. I'd deeply appreciate you help.
I'm confident that it is not a "Network Issue". Both computers are showing appriate IP addresses, and the "fingerprint" was requested and confirmed to match. Both computers reflect constant ongoing log updates showing the attempts and fails. The error I'm getting is as follows:
- When Laptop acts as Client and Desktop as Server

[2020-01-14T09:28:33] NOTE: connecting to 'Shy-Desktop':

[2020-01-14T09:28:33] ERROR: tls error occurred (system call failure)

[2020-01-14T09:28:33] ERROR: failed to connect secure socket

[2020-01-14T09:28:48] WARNING: failed to connect to server: Timed out


[2020-01-14T09:32:38] NOTE: connecting to '':

[2020-01-14T09:32:38] NOTE: server fingerprint: 62:E5:4A:47:D0:AE:28:41:10:F9:84:5B:C0:2C:BA:5E:83:A7:7F:FF

[2020-01-14T09:32:38] INFO: connected to secure socket

[2020-01-14T09:32:38] INFO: server tls certificate info: /CN=Synergy

[2020-01-14T09:32:38] INFO: network encryption protocol: TLSv1.3

[2020-01-14T09:32:38] ERROR: server refused client with name "Shy-Desktop"


Please help me with this. Its driving me crazy. I love this program when it works.

Share this post

Link to post
Share on other sites

Wow. Sorry you had so much hassle... hopefully the support guys will see it here. It looks like an active reject from the server, but I can't tell why from the log snippet.

Share this post

Link to post
Share on other sites

Thanks. Me too.

Clarification: The second set of log is when Laptop acts as Server and desktop is Client.

Sorry if any confusion. Couldn't find a way to edit post.

Share this post

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now